[SOLVED] Generic Thermostat - 'No matching entities found'

I have put the folowing at the end of configuration.yaml

climate:
  - platform: generic_thermostat
    name: benroom_ben_ac
    heater: switch.2_fan
    target_sensor: sensor.h5075_0b91_temperaturen
    max_temp: 40 
    min_temp: 10
    ac_mode: true
    target_temp: 23
    cold_tolerance: 0
    hot_tolerance: 1
    initial_hvac_mode: "off"
    away_temp: 25.5
    precision: 0.1

I then Checked the configuration and did reload ALL YAML CONFIGURATION

When I went to add the Thermostat Card under entity it says ‘No matching entities found’ and to the right

(!) Specify an entity from within the climate domain
type: thermostat

I tried benroom_ben_ac and climate.benroom_ben_ac but does not work.

What am I doing wrong?

Reboot your HA and check then.

Unfortunately “reload all” doesn’t mean it really reloads all the yaml, it means it “reloads all the things that can be reloaded”.

Generic thermostats can generally be reloaded, but the platform won’t be setup until HA boots at least once with at least one generic thermostat, so you need to reboot the first time to get it going. After that, any changes you make or new thermostats you add can be hot reloaded.

1 Like

Do not reboot the host machine.

Just restart Home Assistant.

1 Like

Thanks, that did the trick