SOLVED: HA Supervised, Core fail to update to version 2021.5.5

Tags: #<Tag:0x00007fc40fefcb00> #<Tag:0x00007fc40fefc998>

Hello,
I’m using HA supervised on rock64 with 16GB eMMC module(ROCK64 | PINE64) , OS Dietpi.

Current version of Homeassistant Core is core-2021.4.6.

I’ve more than 8GB of free space on the emmc

image

As you can see, supervisor shows that update is pending. But when I try to update I get the following error message. I tried to update through command line too, with the same result.

21-05-20 14:41:48 ERROR (SyncWorker_2) [supervisor.docker.interface] Can't install homeassistant/qemuarm-64-homeassistant:2021.5.5 -> 404 Client Error for http+docker://localhost/v1.41/images/homeassistant/qemuarm-64-homeassistant:2021.5.5/json: Not Found ("no such image: homeassistant/qemuarm-64-homeassistant:2021.5.5: No such image: homeassistant/qemuarm-64-homeassistant:2021.5.5").
21-05-20 14:41:48 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

Can someone help to understand what is the issue.
Thank you!

I have also update issues

21-05-20 22:00:58 INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2021.5.5
21-05-20 22:00:58 INFO (SyncWorker_0) [supervisor.docker.interface] Updating image homeassistant/raspberrypi3-homeassistant:2021.5.4 to homeassistant/raspberrypi3-homeassistant:2021.5.5
21-05-20 22:00:58 INFO (SyncWorker_0) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi3-homeassistant with tag 2021.5.5.
21-05-20 22:01:00 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:2021.5.5 -> 404 Client Error for http+docker://localhost/v1.40/images/homeassistant/raspberrypi3-homeassistant:2021.5.5/json: Not Found ("no such image: homeassistant/raspberrypi3-homeassistant:2021.5.5: No such image: homeassistant/raspberrypi3-homeassistant:2021.5.5").
21-05-20 22:01:00 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed
21-05-20 22:01:00 INFO (MainThread) [supervisor.resolution.module] Create new issue IssueType.UPDATE_FAILED - ContextType.CORE / None

How much disk space do you each have? If you clear some out, does the update work?

I have around 8GB of free space

I am not sure exactly sure how much you need. That’s not much though.

I managed to update with the core-2021.6. version, so it was not an issue with the storage space.