[SOLVED] Homeassistant user password unknown

hi there! i’ve managed to install hassio on a virtual environment of my rpi3b, it’s working fine but i can’t integrate mqtt, so i can’t pair any device.

this guide is what i used to install hassio:

as you can see, i created the homeassistant user, for later creating the virtual environment, but i didn’t create a password for it, the manual didn’t say anything about that.

now i’m stuck, because i can’t edit configuration.yaml of hassio on that virtual environment, i don’t know exactly where’s that file, and the path to it, googling around i’ve been trying things… but everytime i got stuck in the same, almost anything that i do in that virtual environment requires password, that i don’t have.

what can i do? is not there where i should search for configuration.yaml? of what am i missing?

thank you!

That guide didn’t install Hass.io :wink: If you wanted that you need this guide.

The homeassistant user has no password. You use these steps to access that account:

sudo -u homeassistant -H -s
source /srv/homeassistant/bin/activate

actually i did installed hassio that way, i’ve got it running, on chrome (desktop pc) and phone (android), i really got any problem with that, but can’t pair any device because mqtt integration is not working.

can you tell me the default path to home assistant configuration.yaml ? i can’t believe that after hours, can’t find it anywhere.

Hass.io (now simply called Home Assistant) is an install method for Home Assistant (now called Home Assistant Core). If you followed that guide you did not get Hass.io. You got Home Assistant Core. If you wanted Hass.io/Home Assistant you have to use that install method.

This page explains where to find the configuration folder. In your case ~homeassistant/.homeassistant

mmm ok i didn’t knew there was a difference between hassio and home assistant!

anyway, i think that installing home assistant in a virtual environment was a mistake due to my none experience with anything about this, so i made a clean install of home assistant, following the guide you provide me. I’ve got i running, but stuck again

Installed zigbee2mqtt add-on and it gives me an error when connecting to mqtt server, this is the log:

2020-03-28T01:08:38: PM2 log: App [npm:0] exited with code [1] via signal [SIGINT]
2020-03-28T01:08:38: PM2 log: App [npm:0] starting in -fork mode-
2020-03-28T01:08:38: PM2 log: App [npm:0] online

[email protected] start /zigbee2mqtt-1.12.0
node index.js
zigbee2mqtt:info 2020-03-28 01:08:43: Logging to console and directory: ‘/share/zigbee2mqtt/log/2020-03-28.01-08-43’ filename: log.txt
zigbee2mqtt:info 2020-03-28 01:08:44: Starting zigbee2mqtt version 1.12.0 (commit #unknown)
zigbee2mqtt:info 2020-03-28 01:08:44: Starting zigbee-herdsman…
zigbee2mqtt:info 2020-03-28 01:08:46: zigbee-herdsman started
zigbee2mqtt:info 2020-03-28 01:08:46: Coordinator firmware version: ‘{“type”:“zStack12”,“meta”:{“transportrev”:2,“product”:0,“majorrel”:2,“minorrel”:6,“maintrel”:3,“revision”:20190608}}’
zigbee2mqtt:info 2020-03-28 01:08:46: Currently 0 devices are joined:
zigbee2mqtt:info 2020-03-28 01:08:46: Zigbee: disabling joining new devices.
zigbee2mqtt:info 2020-03-28 01:08:46: Connecting to MQTT server at mqtt://core-mosquitto
events.js:200
throw er; // Unhandled ‘error’ event
^
Error: Connection refused: Not authorized
at MqttClient._handleConnack (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:1076:15)
at MqttClient._handlePacket (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:365:12)
at work (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:283:12)
at Writable.writable._write (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:294:5)
at doWrite (/zigbee2mqtt-1.12.0/node_modules/readable-stream/lib/_stream_writable.js:428:64)
at writeOrBuffer (/zigbee2mqtt-1.12.0/node_modules/readable-stream/lib/_stream_writable.js:417:5)
at Writable.write (/zigbee2mqtt-1.12.0/node_modules/readable-stream/lib/_stream_writable.js:334:11)
at Socket.ondata (_stream_readable.js:728:22)
at Socket.emit (events.js:223:5)
at addChunk (_stream_readable.js:309:12)
Emitted ‘error’ event on MqttClient instance at:
at MqttClient._handleConnack (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:1078:10)
at MqttClient._handlePacket (/zigbee2mqtt-1.12.0/node_modules/mqtt/lib/client.js:365:12)
[… lines matching original stack trace …]
at addChunk (_stream_readable.js:309:12) {
code: 5
}
npm
ERR! code ELIFECYCLE
npm
ERR!
errno 1
npm
ERR! [email protected] start: node index.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Did you install a mqtt broker?

Yes, i forgott to say that. I’ve installed Mosquitto broker add-on, but i got problems with it, i don’t think its working, look at the log of mosquitto:

[18:57:52] INFO: Setup mosquitto configuration
[18:57:53] WARNING: SSL not enabled - No valid certs found!
[18:57:53] INFO: No local user available
[18:57:53] INFO: Initialize Hass.io Add-on services
[18:57:54] INFO: Initialize Home Assistant discovery
[18:57:54] INFO: Start Mosquitto daemon
1585418274: Loading config file /share/mosquitto/acl.conf
1585418274: mosquitto version 1.6.3 starting
1585418274: Config loaded from /etc/mosquitto.conf.
1585418274: Loading plugin: /usr/share/mosquitto/auth-plug.so
1585418274: ├── Username/password checking enabled.
1585418274: |-- *** auth-plug: startup
1585418274: ├── TLS-PSK checking enabled.
1585418274: └── Extended authentication not enabled.
1585418274: Opening ipv4 listen socket on port 1883.
1585418274: Opening ipv6 listen socket on port 1883.
1585418274: Opening websockets listen socket on port 1884.
1585418274: Warning: Mosquitto should not be run as root/administrator.
1585418274: New connection from 172.30.xx.xx on port 1883.
[ERROR] Auth error with my_user
1585418277: Socket error on client , disconnecting.

I don’t know what is that ip starting for 172, it’s local? because it’s not my external ip.

OK news here, finaly, i’ve reviewed all config, made some changes, and a full reset of home assistant and all the add-ons, GOT IT WORKING! i’ve already paired 2 devices, but sadly i’ve no success on seeing them on home assistant ui, the log says it’s ok but i’m missing something and i don’t know what is it. Any suggest? thank you!

zigbee2mqtt:info 2020-03-29 05:27:09: Logging to console and directory: ‘/share/zigbee2mqtt/log/2020-03-29.05-27-09’ filename: log.txt
zigbee2mqtt:info 2020-03-29 05:27:10: Starting zigbee2mqtt version 1.12.0 (commit #unknown)
zigbee2mqtt:info 2020-03-29 05:27:10: Starting zigbee-herdsman…
zigbee2mqtt:info 2020-03-29 05:27:12: zigbee-herdsman started
zigbee2mqtt:info 2020-03-29 05:27:12: Coordinator firmware version: ‘{“type”:“zStack12”,“meta”:{“transportrev”:2,“product”:0,“majorrel”:2,“minorrel”:6,“maintrel”:3,“revision”:20190608}}’
zigbee2mqtt:info 2020-03-29 05:27:12: Currently 2 devices are joined:
zigbee2mqtt:info 2020-03-29 05:27:12: 0x0017880103db7b0c (0x0017880103db7b0c): 8718696548738 - Philips Hue white ambiance E26/E27 (Router)
zigbee2mqtt:info 2020-03-29 05:27:12: 0x7cb03eaa00b0c107 (0x7cb03eaa00b0c107): AB3257001NJ - OSRAM Smart+ plug (Router)
zigbee2mqtt:info 2020-03-29 05:27:12: Zigbee: disabling joining new devices.
zigbee2mqtt:info 2020-03-29 05:27:12: Connecting to MQTT server at mqtt://core-mosquitto
zigbee2mqtt:info 2020-03-29 05:27:12: Connected to MQTT server
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘zigbee2mqtt/bridge/state’, payload ‘online’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘zigbee2mqtt/bridge/config’, payload ‘{“version”:“1.12.0”,“commit”:“unknown”,“coordinator”:{“type”:“zStack12”,“meta”:{“transportrev”:2,“product”:0,“majorrel”:2,“minorrel”:6,“maintrel”:3,“revision”:20190608}},“log_level”:“info”,“permit_join”:false}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/light/0x0017880103db7b0c/light/config’, payload ‘{“brightness”:true,“color_temp”:true,“schema”:“json”,“command_topic”:“zigbee2mqtt/0x0017880103db7b0c/set”,“state_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“json_attributes_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“name”:“0x0017880103db7b0c_light”,“unique_id”:“0x0017880103db7b0c_light_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x0017880103db7b0c”],“name”:“0x0017880103db7b0c”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Hue white ambiance E26/E27 (8718696548738)”,“manufacturer”:“Philips”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/sensor/0x0017880103db7b0c/linkquality/config’, payload ‘{“icon”:“mdi:signal”,“unit_of_measurement”:“lqi”,“value_template”:"{{ value_json.linkquality }}",“state_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“json_attributes_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“name”:“0x0017880103db7b0c_linkquality”,“unique_id”:“0x0017880103db7b0c_linkquality_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x0017880103db7b0c”],“name”:“0x0017880103db7b0c”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Hue white ambiance E26/E27 (8718696548738)”,“manufacturer”:“Philips”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/binary_sensor/0x0017880103db7b0c/update_available/config’, payload ‘{“payload_on”:true,“payload_off”:false,“value_template”:"{{ value_json.update_available}}",“state_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“json_attributes_topic”:“zigbee2mqtt/0x0017880103db7b0c”,“name”:“0x0017880103db7b0c_update_available”,“unique_id”:“0x0017880103db7b0c_update_available_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x0017880103db7b0c”],“name”:“0x0017880103db7b0c”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Hue white ambiance E26/E27 (8718696548738)”,“manufacturer”:“Philips”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/switch/0x7cb03eaa00b0c107/switch/config’, payload ‘{“payload_off”:“OFF”,“payload_on”:“ON”,“value_template”:"{{ value_json.state }}",“command_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107/set”,“state_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“json_attributes_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“name”:“0x7cb03eaa00b0c107_switch”,“unique_id”:“0x7cb03eaa00b0c107_switch_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x7cb03eaa00b0c107”],“name”:“0x7cb03eaa00b0c107”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Smart+ plug (AB3257001NJ)”,“manufacturer”:“OSRAM”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/sensor/0x7cb03eaa00b0c107/linkquality/config’, payload ‘{“icon”:“mdi:signal”,“unit_of_measurement”:“lqi”,“value_template”:"{{ value_json.linkquality }}",“state_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“json_attributes_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“name”:“0x7cb03eaa00b0c107_linkquality”,“unique_id”:“0x7cb03eaa00b0c107_linkquality_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x7cb03eaa00b0c107”],“name”:“0x7cb03eaa00b0c107”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Smart+ plug (AB3257001NJ)”,“manufacturer”:“OSRAM”},“availability_topic”:“zigbee2mqtt/bridge/state”}’
zigbee2mqtt:info 2020-03-29 05:27:12: MQTT publish: topic ‘homeassistant/binary_sensor/0x7cb03eaa00b0c107/update_available/config’, payload ‘{“payload_on”:true,“payload_off”:false,“value_template”:"{{ value_json.update_available}}",“state_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“json_attributes_topic”:“zigbee2mqtt/0x7cb03eaa00b0c107”,“name”:“0x7cb03eaa00b0c107_update_available”,“unique_id”:“0x7cb03eaa00b0c107_update_available_zigbee2mqtt”,“device”:{“identifiers”:[“zigbee2mqtt_0x7cb03eaa00b0c107”],“name”:“0x7cb03eaa00b0c107”,“sw_version”:“Zigbee2mqtt 1.12.0”,“model”:“Smart+ plug (AB3257001NJ)”,“manufacturer”:“OSRAM”},“availability_topic”:“zigbee2mqtt/bridge/state”}’

I’m going crazy with this but i almost have it… I think my problem is that i have to do this, but i don’t know how.

because i don’t know why my configuration.yaml is so different to what i see over the internet, mine looks like this:

any help?

OK, i think the thread can be marked as solved, because the title was “user password unknown” and that is actually solved. Will open a new thread with the new failures i’ve got now. Thank you for your replys.