[SOLVED] Raspberry Pi4 + docker + homeassistant/raspberrypi4-homeassistant


I have installed Raspbian Buster Lite latest image (September 2019) and installed docker.
After this I have run the command:

docker run -d \
--name="hass" \
--net=host \
--restart on-failure \
-e "TZ=Europe/Bucharest" \

Home assistant server is up and runing, but Hass.IO button is not available and I am getting this error in logs:

2019-11-26 13:29:08 ERROR (MainThread) [aiohttp.server] Unhandled exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_protocol.py", line 461, in start
    await prepare_meth(request)
  File "/usr/local/lib/python3.7/site-packages/aiohttp/web_fileresponse.py", line 224, in prepare
    st = await loop.run_in_executor(None, filepath.stat)
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/pathlib.py", line 1168, in stat
    return self._accessor.stat(self)
FileNotFoundError: [Errno 2] No such file or directory: '/config/home-assistant.log'

Am I doing something wrong?

I’m not an expert, but it looks like you missed the -v parameter to map the local storage for /config

Thanks for replying!

I thought that the -v parameter is only if you want to map your config folder outside of the docker env.
First time I tried with mapping and got the same error, then I have removed it to reduce the possible errors.

I just did a quick test on my laptop straight from the documentation. I created a folder in my home directory and mapped /config to that. It seems to work.

doug$ docker run --init -d --name="home-assistant" -e "TZ=America/New_York" -v /Users/doug/homeassistant:/config -p 8123:8123 homeassistant/home-assistant:stable

Thank you,
I also have it runing in a laptop with Ubuntu Server and all is fine. The problem is with the RPI4 image only.

1 Like

Because you didn’t install hassio. You are running Home Assistant in Docker, not Hassio.

There is literally an entire section of the install guide dedicated to installing hassio on docker on a generic linux environment.

Thank you very much! I have it now running fine.