[solved] Sonoff Mini: no diy jumper pins on board and no clue how to tasmotize it

Tags: #<Tag:0x00007f326bee0418> #<Tag:0x00007f326bee0350>

Hi everybody!

just bought a sonoff mini, and there are no diy jumper pins inside. I’ve only upgraded the fimware via ewelink, from 3.5 to 3.6.
I tried to follow all the tutorial and videos on line but no luck. all I got is a pingable device, connected in diy mode (I guess) to my wifi lan but if i start the OTA flashing procedure via rester POST commands, it doesnt connect.
I already flashed a few sonoff basicr3 so I know I’m missing something Mini-specific…
any help? has anybody already dealt with those no-jumper sonoffs?

I never bothered to check if there were anything like “DIY Mode” jumper pins, I just reflashed all of mine the typical way by connecting to it via serial and reflashing like normal.
I can confirm that this method works perfectly.

1 Like

I followed the written instructions and managed to get the device into DIY mode.

I then used the old host an image method to upload tasmota-lite.bin.

I ended up with a semi-bricked device so wired up the UART interface to flash as per the previous response.

I have had safety issues with Sonoff devices so moving forward I’m going touse Shelly’s which look as small but are designed to be messed around with so have built in pin headers etc.

thanks everybody.
my bad: when connected to the device’s own access point, IP 10.10.7.1, I entered my LAN wifi credentials instead of the “sonoffDiy” hotspot ones.
Everything went on smoothly then, it’s a 5 minutes job and no need to mess with jumpers or soldering irons.

Hello,
It sounds like you finally managed it… I could not!
I followed the instructions here
https://tasmota.github.io/docs/Sonoff-DIY/
but nothing… the hotspot instructions you mentioned are the ones from most popular tutorials like Dr ZZs ones?
Anybody else having issues?
To clarify I purchased recently a few sonoff mini and none of them come with the jumper but they to allow DYI mode so there must be a way (yes I know I can solder and I have done it in the past but I am really not good at it and I would have to do it in 6 or 7 devices so I would like to avoid it hhehe

thank you all in advance for any reply

I got had the same issue @avernali this video got me going in the right direction https://www.youtube.com/watch?v=RYIluZDaAFs
not the best video quality but great info

WARNING the video has extra steps that are not needed, you dont need the diyhotspot at all.

what you do is this:

  • Connect the mini to power
  • Hold the button in for 5 seconds (count slow) when you see the button’s led change then you can let go.
  • if the LED is blinking fast then you are in wifi mode
  • Grab your phone, connect to the itead-********** wifi network (pw: 12345678)
  • If you cannot connect to it right away, remove the network from your saved networks and try again (sometimes takes a few trys for some reason)
  • once connected to the wifi go to 10.10.7.1
  • follow the instructions on the page and give in your routers wifi credentials.
  • go to the video and follow what the guy does (i timestamped it) https://youtu.be/RYIluZDaAFs?t=225

I just flashed tasmota on 10 minis with this method so i can confirm it works, good luck!

1 Like

That is fantastic, thank you very much!
I got to the point where I had the otaUnlock: true but after that the written instructions said: “flash it according to instructions everywhere on the Internet” but that was just not possible as, for example, using the DYI tool I could not see my device, even if I had put in there my routers wifi credentials (and not making that sonoffDiy network like it says in 2543 tutorials out there).
I actually gave up and thought I would simply use the AlexxIT way (that works pretty well) but since I have 2 devices already where I got to the point of the last of the bullet points you wrote…I will follow the video and give it a try!

Thanks again for the help and the detailed instructions!

I followed this youtube https://www.youtube.com/watch?v=FoJT5pJDEL4&list=LL&index=6&t=76s for some of the Sonoff Mini (very easy) and for others used serial connection from my Jig. Copied an idea of Superhouse.


Takes just few mins to connect to the pads. Tried for hours to solder directly to pads, but would get 3 soldered then one would fall off. In this pic I have to connect to pads on this light socket on both sides of PCB.

Did you have any trouble getting back to the 10.10.7.1 page after doing this? I initially used my local network SSID but even though I can get the device back in to compatibility mode and connect to the ITEAD-*** network, I just can’t get that 10.10.7.1 page to load, in order to change the SSID.

Any tips, or did it just work?

I managed to solve my problem with this. I was convinced that I had made a mistake by using my home network credentials for the sonoff, because it wasn’t being detected by the DIY tool. However, I experienced the same problem with a fresh sonoff, while using the sonoffDiy credentials.

After setting otaUnlock to True, using RESTer, I have to restart my laptop and the sonoff whenever I want to use the DIY Tool and then in connects, no matter what network I use, as long as both devices are connected to the same Network.