[SOLVED] - Unraid/Home Assistant/ESPHome - Can't install

Hi, while I have had HA up and running for awhile, I am still (overall) a nubie. I am trying to install ESPHome and I have question after question and youtubes and documentaion have not been a lot of help so I am coming to the forum.
I am running Home Assistant Core (Ver: core-2021.7.1) on Unraid (Ver: 6.9.2). I try to install ESPHome on HA from the Configuration => Add Configuration => ESPHome and it asks for the Host and the Port. I input the host and the leave the port at 6053 and I get a error line that says “Can’t connect to ESP. Please make sure your YAML file contains an ‘api:’ line.”
Thinking HA ESPHome might just be a dashbaord and it may be trying to connect to a running app I intall the Unraid ESPHome docker and then the HA ESPHome, specifying the correct port. Same error. I tried to add a node from the Unraid docker then install the HA version. Same error.
Do I need the Unraid ESPHome docker running or is the HA the same thing? Quiet clueless as to where to go from here.

I think you are missing something here, You need to use esphome addon or docker to create the actual ESP The node that will have the code on it then that one will then connect to HA via that esp’s IP_ADRESS:PORT in the dialog you are trying to use.

Follow this or add the ESPHome docker directlly on unRAID

Thanks for the help DrJeff. I have actually already tried this but it didn’t work because the link fails, but through searching and a bit more enlightenment, I found it’s because my version of HA does not have Supervisor mode. I think I need to revamp my HA because I am using the Core version which is too archaic. That’s going to be my next step. Again, thanks for the help.

OrangeLoon

What you are trying to do does not install esphome. It is the second part of the process, adding a device plashed with esphome to home assistant so it appears as a device with entities.

What you need to do is actually install esphome. Follow Getting Started with ESPHome — ESPHome

Thanks Nick. I actually got ESPHome installed as a docker via help from digiblurDIY and I have created the first node and now at “How do you want to install this on your ESP device?” but that’s as far as I can get. Here are the options:

  • Wireless - not an option because the device is not online.

  • Plug into this computer - Dashboard needs to be opened via HTTPS. I have an SSL certificate for on my Unraid but cannot find how to open the dashboard via HTTPS. I believe I need a reverse proxy and looking for updated (2020+ instructions) that matches (or gets close) to Unraid 6.9 - still searching.

  • Plug into the computer that is running the ESPHome Dashboard - Thats the Unraid box but no ports show up so I figure I need to install the drivers on the link you sent. Researching how to install drivers on Unraid. I see conflicting details and I don’t know if I need to install for the computer or for the specific docker and haven’t found instructions for either. There are instruction for loading a driver on Linux but that does not work on Unraid.

  • Manual download - I can do this! download to my Windows computer. I tried to find how to load the firmware via ESPEasy - not a freakin’ clue. I did not find a windows install and I see where several sites have deprecated documentation referring to a ESP Easy Web interface but have yet to find a link.

And that is where I am.

Use esphomeflasher.

Done!!! Thanks for the help and the patience.

1 Like

I’m also stuck here, getting a message about ensuring that my YAML file contains an API line.

I successfully added an ESP32 device to UnRaid, added the ESPHome Docker, but I’m stuck adding the ESPHome integration.

I want to flash my ESP32 device next, so please help with adding the integration. I’m an HA newb BTW, in case that wasn’t painfully obvious.