(SOLVED) Z-Wave JS & Polling

I just upgraded to Z-Wave JS and everything is working. I do have an issues that I solved in the past with polling, but I understand that we currently don’t have a method to poll zwave switches.

I have an automation (using a blueprint) for a Wenzhou ZWN-RSM1, to turn on the light connected to the switch and 3 (plug-in) switches when the wall switch is manually turned on. Additionally, when the switch is turned off, I turn off the same switches.

The problem I’m having with Z-Wave JS is that when I press the wall switch I do not see the state change in Developer Tools, so there is no way to detect the on to off or off to on conditions. I was using a polling_intensity for this device and that worked well before, what are my options now?

Did you find a solution. I have the same issue.

The only solution I have at the moment is to use my Echo to trigger the automation which turns on the light and switch.

This is old so I figure you found out a solution, but since I found it via google others may as well. It seems the service zwave_js.refresh_value allows you to poll devices. If you set this in a time pattern then it should do the trick. It worked for me anyways.


Thank you!
This was exactly what I needed

Thanx, i have some Heatit Z -TRM3, thermostats that i could not for the life of me understand why tay where not updating status Idle/heating. After what i understand the firmware in these thermostats is not configured to push status updates to the controller. But needs to be POLLED.
In my opinion HA should poll thes devices (some kind zwave js internal config that KNOWS these thermostats needs to be polled for status updates) For now the status gets polled via the zwave refresh automation from here.

I know this is extremely old but if anyone is looking at this, I was able to set my automation to refresh just the device I needed to poll on trigger (instead of doing it at a set interval and for multiple devices). I did have to put in a 500ms delay to allow the value to update before checking it in the automation, otherwise it would still see the old value and not run properly.

Here, I’m turning a light off after 5 minutes if all the doors are closed and there is no motion, and if the switch brightness is below 51.

  - service: zwave_js.refresh_value
      entity_id: light.in_wall_paddle_dimmer_300s
  - delay:
      hours: 0
      minutes: 0
      seconds: 0
      milliseconds: 500
  - if:
      - condition: and
          - condition: numeric_state
            entity_id: light.in_wall_paddle_dimmer_300s
            attribute: brightness
            below: 51
          - type: is_no_motion
            condition: device
            entity_id: binary_sensor_motion
            domain: binary_sensor
          - type: is_not_open
            condition: device
            entity_id: binary_sensor.centralitel_door
            domain: binary_sensor
          - type: is_not_open
            condition: device
            entity_id: binary_sensor.front_door
            domain: binary_sensor
      - delay:
          hours: 0
          minutes: 5
          seconds: 0
          milliseconds: 0
      - type: turn_off
        entity_id: light.in_wall_paddle_dimmer_300s
        domain: light

I was running into the same issue with some of my devices. This post got things going for me. I don’t know if you had to use just the yaml config when this post was originally created. I was able to create the automation using the UI which made it really easy.

I have a question. What model light switches are you using? I have 500 series and newer devices and in my experience you should NEVER have to poll a device to get updates. As long as your associations are properly setup the devices should automatically report changes. The associations get set automatically during inclusion but I’ve seen instances where this doesn’t happen and I’m wondering if that’s the case here.

I have a mixed bag of devices. I replaced just about all of the switches in my house to be smart switches or dimmers many years ago. I have some by GE (12724 / ZW3005) which tend to be the devices that give me the most issues. However, I have those dimmers in other areas and they don’t have any issues.

For a while now I was using the Samsung Smartthings hub to control all the Z-Wave devices. I thought maybe the connection between that hub and Home Assistant could be causing issues. So I ditched that and got a Z-Wave USB stick and re-configured everything from scratch, including Home Assistant. I also moved the hub from my basement to the main floor of the house to have a more central position. Still, ran into the issue where switches wouldn’t show the correct status.

Yeah, I understand that the devices should “NEVER” have to be polled via script/automation. I have many devices that are working without issue. My setup consists of roughly 30 Z-Wave devices. However, when reality hits and things don’t work right, then it’s time for a workaround.

If you go into the groups menu does it look like mine? If it does can you click the add button and take a pic of the options in the groups list. You have to select an endpoint before it shows you the group options. If it doesn’t look like my picture can you still take a photo so I can see what it looks like?

I guess I don’t know what “The Groups” menu is. I looked around my instance and couldn’t find it.

You can only access the groups menu if you are using the ZWaveJSUI addon.

I see what you’re talking about now. I actually don’t have the JS Z-Wave UI add-on installed. I’m just using the default Z-Wave JS controller. I tried to install just that and got a 404 error saying something couldn’t be found. If it were an easy install I’d go with it. But, since it’s not installing correctly on its own, I’m not going to tinker with it right now. Sorry.