(Some) Wemo devices gone after 0.94?

Seems like I lost a bunch of Wemo switches in the 0.94 update. Some are there! Some (mostly newer Wemo Minis) are not. I’ve got default_config: on, I’ve got wemo: on in the config as well. Has anyone else seen or dealt with this?

I’m seeing this too but only Wemo Link devices, i.e. Wemo LEDS

I had the same experience and fixed it by entering the following in configuration.yaml

wemo:
  discovery: true

Perhaps discovery is false by default in 0.94

Hi,

I’m still having the same issue. Have tried multiple combinations of ssdp:, discovery: and wemo: in the configuration.yaml, but some reason HA failes to discover my WeMo motion sensor. WeMo switches seems to work fine.

This issue is only happening on one wemo dimmer I have, and it’s one that I have had an issue with since I purchased it back in november. Up until now I have been able to use it while setting all my wemo devices statically, but now, after .94.*, if they are set static they are not usable. If I remove the static line and address for this problematic dimmer in the config, then every device except the wemo dimmer works. I have one other dimmer on my network that still works perfectly, and I don’t see anything in the logs as far as why this doesn’t work.

I might have some time this weekend to dig in further into troubleshooting, but without any errors in the log I wont really know where to start.

Does anyone else see any errors in their logs related to the wemo component?

Just kidding, finally got it to give me an error:

019-06-25 20:01:47 ERROR (MainThread) [homeassistant.core] Error doing job: Future exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/wemo/__init__.py", line 152, in discover_wemo_devices
    device = pywemo.discovery.device_from_description(url, None)
  File "/usr/local/lib/python3.7/site-packages/pywemo/discovery.py", line 45, in device_from_description
    uuid = deviceParser.parseString(xml.content).device.UDN
  File "/usr/local/lib/python3.7/site-packages/pywemo/ouimeaux_device/api/xsd/device.py", line 1596, in parseString
    doc = parsexml_(BytesIO(inString))
  File "/usr/local/lib/python3.7/site-packages/pywemo/ouimeaux_device/api/xsd/device.py", line 64, in parsexml_
    doc = etree_.parse(*args, **kwargs)
  File "src/lxml/etree.pyx", line 3435, in lxml.etree.parse
  File "src/lxml/parser.pxi", line 1857, in lxml.etree._parseDocument
  File "src/lxml/parser.pxi", line 1877, in lxml.etree._parseMemoryDocument
  File "src/lxml/parser.pxi", line 1765, in lxml.etree._parseDoc
  File "src/lxml/parser.pxi", line 1127, in lxml.etree._BaseParser._parseDoc
  File "src/lxml/parser.pxi", line 601, in lxml.etree._ParserContext._handleParseResultDoc
  File "src/lxml/parser.pxi", line 711, in lxml.etree._handleParseResult
  File "src/lxml/parser.pxi", line 640, in lxml.etree._raiseParseError
  File "<string>", line 103
lxml.etree.XMLSyntaxError: Char 0x0 out of allowed range, line 103, column 1

Any way I can get you (and anyone else) to post your error logs?

@angel12
I am running 98.5 after rebuilding from an 88.4 crash and burn Hassio on Rpi. Since I installed it, all my fauxmo wemo switches are getting an error box “failed to.call swit_turnon.no element found: line 1 column 0” and the error trace looks like:

Log Details (ERROR)
Wed Oct 09 2019 17:40:02 GMT-0400 (Eastern Daylight Time)
Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/script.py”, line 151, in async_run
await self._handle_action(action, variables, context)
File “/usr/src/homeassistant/homeassistant/helpers/script.py”, line 235, in _handle_action
await self._actions[_determine_action(action)](action, variables, context)
File “/usr/src/homeassistant/homeassistant/helpers/script.py”, line 318, in _async_call_service
context=context,
File “/usr/src/homeassistant/homeassistant/helpers/service.py”, line 98, in async_call_from_config
domain, service_name, service_data, blocking=blocking, context=context
File “/usr/src/homeassistant/homeassistant/core.py”, line 1213, in async_call
processed_data = handler.schema(service_data)
File “/usr/local/lib/python3.7/site-packages/voluptuous/schema_builder.py”, line 272, in call
return self._compiled([], data)
File “/usr/local/lib/python3.7/site-packages/voluptuous/schema_builder.py”, line 594, in validate_dict
return base_validate(path, iteritems(data), out)
File “/usr/local/lib/python3.7/site-packages/voluptuous/schema_builder.py”, line 432, in validate_mapping
raise er.MultipleInvalid(errors)
voluptuous.error.MultipleInvalid: extra keys not allowed @ data[‘service’]

I have no clue what the trace is trying to tell me but the switches will actually work. I get the error when I turn them on or off (switch.turnoff.no element…)

Any thoughts on what to do about this? I’ve rebooted many times but it persists.

Thanks in advance.