Somfy Tahoma Official API


#106

Sadly, the official API does not yet support sensors.


#107

Ok
Chat about dimmer support?


#108

Not yet supported too.


#109

@tetienne have you any solution for me? I must say to google home “Open blinds” if i want close. :smiley:


#110

Hi,
Can you please use exactly the code I have on my repo: here and here. Don’t forget to update the import path.


#111

UP/DOWN buttons work OK
UP/DOWN slider work OK
Open/close buttons work good, but if are full open, show button for open and if full closed show button only for close
Open/close slider wierd, firs first look shows reverse, but if i open about 10 points, open it 90 points and show 10. :open_mouth:


#112

Hi, I will continue to investigate your case in PM to avoid noise here.


#113

@tetienne some feedback after i tried your component :

I have 3 RTS covers,i followed your guide and they all came into Hass.

  1. If the covers are open and i click the arrow down one by one not all will go down, some will and some will never do down, some will do it right away some will do it later.
  2. If i use one and click down and then after few seconds click Stop then nothing happens.
  3. If while the covers is going down i click up nothing happens but after the cover is down it may go up later (sometime).
  4. The history does not show that i clicked up/down. Could that be added ? I mean i know they are RTS and they give no feedback but it would be nice to know if an automation has asked them to go wither up or down.

Problem 1-3 could be caused by Somfy API not beeing able to take more commands once, making a queue, or the fact that my Conexxoon too far away from the covers although my experience is that 433mhz is actually reaching quite far.

/donnib


#114

Thx for your feedback. Indeed, for 1-3 it’s related to the Somfy API behavior. @gieljnssns already met the issue about the stop button. The command is well sent but nothing happened, or sometimes yes. Did you see any errors 500 in the log? It can explain why all the covers does not go down. I will ping again the Somfy support.


#115

I got some review on Pull Request. I have to use the Config entry framework. It will avoid to create a cache file .somfy and Somfy component will be available in the integration menu.


#116

Yes i also think it’s the Somfy API that is the problem here. I think it would be great to report to them that it behaves weird. To be honest i see some weird issues that are very similar with the Somfy Conexxoon app which again indicates the API.


#117

I see a bunch of these errors in the log :

Update for cover.dr fails Traceback (most recent call last): File "/usr/local/lib/python3.6/site-packages/requests_oauthlib/oauth2_session.py", line 330, in request http_method=method, body=data, headers=headers) File "/usr/local/lib/python3.6/site-packages/oauthlib/oauth2/rfc6749/clients/base.py", line 196, in add_token raise TokenExpiredError() oauthlib.oauth2.rfc6749.errors.TokenExpiredError: (token_expired)

and the component is not working anymore, i made the token yesterday and it’s set to never expire on Somfy API.


#118

I got the same today. And when I tried to renew the token, Somfy returned an error too. Their server seems to be so unstable :frowning:


#119

Yes seems like it…hmmm.


#120

Any luck, i tried again today and still not working, it’s hard to believe they broke it and they haven’t fixed it yet, could they have changed something so you need to change something ?


#121

Trust me, it won’t be the first time it happens. Two months ago, their API was down during a whole week end. I don’t know what they do, and I hope this API is not a side project with little resource :S


#122

Ouch…that seems pretty bad. Did they reach when you talked with them ?


#123

I wrote to them and now it’s fixed i can see.


#124

@tetienne i tried to make a cover group as described here : https://www.home-assistant.io/components/cover.group/ so i can control all 3 covers which are of same type together but the group in HASS only shows the button for down and the up button is greyed out and keeps beeing greyed out regardless what i do with the covers obviously HASS doesn’t know whether they are up or down but i was expecting both buttons to be enabled.Any ideas what may cause this ? Is this a bug in HASS ?


#125

Did you compare with the Tahoma component?