Sonoff Basic R3 flashed with Tasmota-lite v9.1.0 not discovered in Integration

Tags: #<Tag:0x00007f325ed09ef8> #<Tag:0x00007f325ed09e30> #<Tag:0x00007f325ed09d68>

Hi. I’ve been struggling with configuring a Sonoff R3 switch flashed with tasmota-lite.bin v9.1.0.

I am running Home Assistant 0.117.6 with Operating System HassOS 4.16 on a Raspberry Pi 3 B 1GB.
Bought a Sonoff DIYBASICR3 switch and flashed tasmota-lite.bin v9.1.0. Configured Wi-Fi same as HA.
Added a user/passwd ‘mqttuser’ to use for the switch
Installed Mosquitto broker v5.1 add-on with settings on default
Added the MQTT Integration and used broker HA IP, default port, user/passwd ‘mqttuser’ defined in Configuration > Users
On Tasmoda webpage I changed the template with {“NAME”:“Basic R3”,“GPIO”:[17,255,0,255,255,0,255,255,21,56,0,0,255],“FLAG”:0,“BASE”:1}
After reset I updated in Configure MQTT page Host to HA IP, user/passwd to the ‘mqttuser’
In the Console I set SetOption19 > 20:42:12 MQT: stat/tasmota_4B4F22/RESULT = {“SetOption19”:“ON”}

I do not have anything in configuration.yaml added manually for the mqtt

Checked the log for Mosquitto broker:
[21:21:41] INFO: Setup mosquitto configuration
[21:21:41] INFO: No local user available
[21:21:42] INFO: Initialize Hass.io Add-on services
[21:21:42] INFO: Initialize Home Assistant discovery
[21:21:42] INFO: Start Mosquitto daemon
1605295302: mosquitto version 1.6.3 starting
1605295302: Config loaded from /etc/mosquitto.conf.
1605295302: Loading plugin: /usr/share/mosquitto/auth-plug.so
1605295302: ├── Username/password checking enabled.
1605295302: |-- *** auth-plug: startup
1605295302: ├── TLS-PSK checking enabled.
1605295302: └── Extended authentication not enabled.
1605295302: Opening ipv4 listen socket on port 1883.
1605295302: Opening ipv6 listen socket on port 1883.
1605295302: Opening websockets listen socket on port 1884.
1605295302: Opening ipv4 listen socket on port 8883.
1605295302: Opening ipv6 listen socket on port 8883.
1605295302: Opening websockets listen socket on port 8884.
1605295302: Warning: Mosquitto should not be run as root/administrator.
1605295304: New connection from 192.168.1.169 on port 1883.
[INFO] found mqttuser on Home Assistant
1605295305: New client connected from 192.168.1.169 as auto-F1EB0B47-C362-961B-C6A4-E9DFE9C5BAC0 (p2, c1, k60, u’mqttuser’).
1605295309: New connection from 192.168.1.17 on port 1883.
1605295309: New client connected from 192.168.1.17 as DVES_4B4F22 (p2, c1, k30, u’mqttuser’).

In the MQTT integration > Configure page I can send topic ‘cmnd/tasmota_4B4F22/POWER toggle’ and my switch will change state but it will not get discovered nor can I see any new entity in order to use this.

I would appreciate any suggestions. Thanks.

Tasmota lite doesn’t support MQTT discovery. Upgrade to full Tasmota if you want that. Alternatively, you can disable SetOption19 and use the switch with the Tasmota integration which is currently a beta integration.

interesting. could not find this info. i tried to flash tasmota.bin but the image is to big? shoul it work to flash from tasmota lite web interface or only using the usb-ttl cable?

Do the OTA update or manually update with tasmota.bin.gz

1 Like

Thanks. It worked. Maybe I did not read all the info but it was not clear to me:

  1. that you cannot flash tasmota.bin but with tasmota.bin.gz it works
  2. that tasmota-lite.bin does not have mqtt discovery even if in the settings seem to be supported

Now the switch is working as expected. Many thanks.

PS: this is my modified pcb in order to use the R3 to switch a central heating (dry relay). was cut with dremel small circular blade and cleaned with conic small metal grinder. the live line is really thick… you need to cut all the way to the other side and make sure all is cut. 240V is no joke! stay safe!