Sonoff ch4 Pro R3 not able to flash esphome

After a week of trying to get esphome yaml flashed on the Sonoff ch4 Pro R3 I still did not succeed. I even bought a new one hoping that would help. Replaced the usb- serial flash device for two others, and tried from macbook, and windoos both with the web.esphome web uploader and with the stand alone flashtool. Used different cables, powered the device and even the usb hub. No luck. Holding the s1 100 button when powering on. The blue led stays of so it is ready to flash. Also changed the wiring to the device from tx and rx and vice versa.
Sow what can I do to get this going. Or better leave this and look for other devices? Wanted to use these for my garden watering project.



Why not use esphome itself? Plug the flasher hardware into your esphome machine and flash from there.

What do you mean? EspHome from HA? That is where I started with this project. Would it be possible to get into the device through its wifi and do some ota? Ofcourse it holds the sonoff software.

Like I tried to say:

Plug the serial device into the machine running you esphome. IE probably the machine running ha.

Flash using the esphome ui.

Ok, now I get it :slight_smile: That would be the RaspberryPi. Might be worth trying :slight_smile: Hope that that will work then.

which guide did you follow?

I did my Sonoff ch4 pro about a year ago; it all worked

The serial device showed up on my MacBook Air; I would have to double check but I think I ran it directly HA and ESPHome dashboard. In other words I did not need to connect to my RaspberryPi directly; where HA runs

@JulianDH I used the instructions from Esphome. And had a look at many other instructions and YouTube. Most of them are with older versions. I have the ch4 Pro r3 . Even bought a second one to make sure it was not a hardware problem from the sonoff device itself.
Beside the esphome flasher, I tried with the on-line web tool and also from HA with the Esphome add-on.
Also tried it connected to a windoos laptop no results there. Looks like the flasher is not getting into the esp-chip somehow. Will try the direct approach to find out if that will help. But I agree that it should work from my Macbook and HA also. Is there a secure way to get the device in flash mode (now I use the button s1 100 when powerig on the device than the blue led stays off(only short a red led is flashing).

On a Mac you can see what is attached to the ports. You need to check you are in flash mode and the port is ready for business.

If so then set up a new yaml using the appropriate code for the Sonoff

Then go to edit

Then click on INSTALL which is on the right hand side; and click on “Plug into this Computer”. It will tell you whether there is something connected on the port still. If not start again.

Somebody may correct me on this; as I did it so long ago and I don’t have a unit in front of me.

Thanks for the example. I did this at start, then I did not get the last screenshot telling me it is connecting. So I will give it an other try again see what happens. Thanks.

On windows you need to install the driver for your serial chip.

I am not sure whether you do on macos.

I know you don’t have to on linux.

No driver needed on my mac air

Edit: it is very clear on Mac OS when serial device is successfully connected

I’ have tried again on the Mac through the espHome HA add-on. It shows my serial device as a choice. When selecting that through “plugged in device”, it opens a panel where it wants to download esphome… which never happens (stays spinning). If I use a newly bought serial device it asks for a driver. So i still use the older serial device which used to work fine.

“Not all requirements are met”

Unsurprisingly didn’t work.

Plug the dang thing into your pi. Then it is the third option in the pop up box.

O getting a bit closer. What does this error mean? Better, what can I do to get it flashed! Looks like the chip is still not communicating with the serial?

The issue seems to be still the same,
no serial connection.

On the image it looks like you have connected TX to TX and RX to Rx
Rx should be connected to Tx and visa-versa.

Have you tried antother serial adapter?
maybe the one you have is broken?
I see your using an FTDI adapter. that should work, but I would suggest to try another one.

In the browser(at least in windows) I shows a list of available com adapters,
So if it’s not in the list you are either missing firmware, or your adapter is not working as it should

I gave up for now. Its taking to much time. Wil use it as it is now. Maybe in the future I try again. I tried with all different serial adapters and changing the connected tx rx applied power etc etc. Maybe it is because the pinhead is not soldered good enough. Might try to improve that also.

On that node,
I never solder the pinhead for sonoff devices.

I just use something like this

connect the 4 wires,
and hold it in place manually while flashing.

My soldering skills aren’t that good, but this works.

Guess what, I did give it a last try using a different usb to serial. And surprisingly it worked. I flashed the damn thing :slight_smile: Now, find out if it gets connected in HA. Learned a lot so that is the positive side of it.
Might flash the other one also to find out if it is going to work as well.
Since this was not succeeding fast enough in the mean-time I tried to flush a Shelby 1 (v3) that also did not work for me so I’m glad the Sonoff ch4 finally came through.

1 Like