Sonoff POW dropping out

Hi to all the Sonoff hackers

I have a mix of Basic, Pow (rev2), 4 channel Pro (rev 2), 3 gang switchs… long story short, I have a problem with the Pow (rev2) just dropping out and not being picked up by hass, going into the tasmo admin is iffey at best… does anyone else experience this?

Flashed “6.4.1(sonoff)”. Do these require different console settings to the other sonoff’s? mqtt enabled, same settings as the remainders, they are picked up by HASS but are offline.

tips appreciated.

Wes

Can you reliably connect to it directly?

Try a dev version of tasmota… that ‘stock’ one is based on core 2.4.2 which is incredibly buggy… try the precompiled binaries for either core 2.5.0 here or 2.3.0 here

Be warned… I have had nothing but trouble recently with precompiled bins for 2.3.0 - causes a boot-loop (7 seconds)

You could also go for the released 6.4.1 with core 2.3.0 and you should find that much more stable.

I am currently running 2.5.0 and it’s pretty solid but still dropouts…

1 Like

Thanks David, will try the 2.5.0 version and report back… I didn’t know about these!!!

Through Tasmo - 86.3% of the time, never through HASS though (same settings as all the other sonoff’s)

I’m not seeing those ones showing as unavailable in TasmoAdmin? (screenshot above) Are they all on the same firmware?

I did a big analysis yesterday. Everytime I saw unavailable on a swuitch it corresponded with a Widi disconnection. The switches furthest from the Wifi master were the most dropouts. 3 switches on a desk next to the master had zero wifi disconnections and zero unavailable. So to me it is definitely a WiFi issue and that is I believe the core version I am using.

2.5.0 is supposed to be ok with FritzBox and Mesh mode… that might be the problem… 2.3.0 was supposed to not like either of those and I never had a disconnection… I don’t know…

1 Like

Hi David

To clarify my pictures, they are all showing up in TasmoAdmin… The 4 sonoff pow R2’s are continually showing a “CURL ERROR => 28: Operation timed out after 5000 milliseconds with 0 bytes” though… this means I can sometimes switch them on off through TasmoAdmin BUT they do not play nicely through MQTT as they timeout.

This happens with the 2.5.0 version as well, do you think it is worth trying the 2.3.0 version?

Regarding Wifi, I have tried these in a few locations, they are not far from AP so are upwards of 80% signal strength. At a guess I think it is a signal delay possibly?!

I do not have any issues with any of the other sonoff basic, sonoff 4 channel rev 2, 3 gang…etc.

Thanks for your input so far :slight_smile:

Well to answer your question

  • via IP address i can get to the device web interface (always)

  • via TasmoAdmin I can interact most off the time

  • via Hass MQTT never

I get the curl errors as well but no problems controlling them.

Last night I asked Google to turn my coffee maker off and she was like ‘talk to the hand’ and I saw that switch was offline… but it would only have been 30 seconds maybe… I also had an occasion last week where an automation with the same switch failed to fire because same thing… the switch was unavailable for 30 seconds right at the wrong time… But that’s not bad… flawless for 12 months previus and just a coincidence…

All I can say is try what works for you… core 2.3.0 has it’s own bugs and issue in the Tasmota Wiki. Probably if I could I’d go back to core 2.3.0…

1 Like

Doesn’t make sense… Are you using MQTT discovery? Are you manually adding the switches? 6.4.1.x changed the topic order.

1 Like

I set Hass to “Enable MQTT discovery for all devices” through automation which runs at startup. I have enabled SetOption19 1 through the console on the web interfaces… they show up in the mosquitto log as being found just won’t show up in HASS.

All the settings are as per the other devices - yet they don’t showup… I have Mosquitto running through Hass, I was thinking maybe I should have an external MQTT broker to eliminate any issues though.

Are you using hass.io?
If you are using MQTT discovery, Have you looked in the integration for MQTT? You’re using the Mosquitto addon broker? If so, you should not have any manually configured at all… You might have switches manually configured but they don’t work because the topic is wrong but they work in tasmoadmin… typically if you use mqtt discovery, your topic would be topic/cmnd or topic/stat etc rather than stat/topic or cmnd/topic

If you remove manually configured switches and just use discovery you should see them in the integration and can click on them there and turn on/off

Also can check in the tasmota console as it will show the full topic etc…

I think you have discovery on which changes the topic but then have manually configured stuff with the wrong topic.

1 Like

Oooooh a little confusing for me, this is the MQTT setup for a sonoff basic that works perfectly

MQTT Host 192.168.1.250
MQTT Port 1883
MQTT User mqtt
MQTT Client sonoff170_kidsfans
MQTT Topic sonoff170-light
MQTT Group Topic sonoffs
MQTT Full Topic sonoff170-light/cmnd/
MQTT Fallback Topic cmnd/sonoff170_kidsfans_fb/

And this is the Sonoff Pow R2 which is super laggy and doesn’t MQTT that well

MQTT Host 192.168.1.250
MQTT Port 1883
MQTT User mqtt
MQTT Client sonoff177
MQTT Topic sonoff177-switch
MQTT Group Topic sonoffs
MQTT Full Topic sonoff177-switch/cmnd/
MQTT Fallback Topic cmnd/sonoff177_fb/

Is there something I am missing?

no those are fine and they confirm that you have mqtt discovery enabled… that is all as I would expect…

but

what is the mqtt config in your configuration.yaml?

what settings did you use in the broker? Hassio addon?

when you added the mqtt integration did you tell HA to enable discovery?

see if it works in tasmoadmin but not in HA then you have screwed up the config somewhere.

FWIW, I have no mqtt: section AT ALL in my config yaml. I have no manually configured mqtt switches at all. I use a home assistant user in all my tasmota devices (username and password) to log into the mqtt broker so my mosquitto broker settings are all defaults. When I added the mqtt integration I enabled discovery.

All my switches show up in the mqtt integration and work perfectly in this setup… (apart from core 2.5.0 dropping out sometimes… of course but that’s a different issue)

1 Like

Configuration.yaml = no MQTT settings

Automations.yaml =

  • alias: Enable MQTT discovery for all devices
    trigger:
    platform: homeassistant
    event: start
    action:
    • service: mqtt.publish
      data:
      topic: sonoffs/cmnd/SetOption19
      payload: ‘1’
      id: 6cab06dbbd344c149d8cf986c1aacd2e

Mosquito Settings Hass
{
“logins”: [
{
“username”: “mqtt”,
“password”: “my password :)”
}
],
“anonymous”: false,
“customize”: {
“active”: false,
“folder”: “mosquitto”
},
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
}

I am pretty sure I screwed it up, not sure how though. My process was to get one working, then production line of copy pasting to get them all the same setup to minimise user error… the only thing that differs is there name which reflects there IP Address. I just can’t think that I would have stuffed up 4 the same, whilst the other 12 work fine. I’ll restart HASS Again to see if any changes.

David Thanks for your input so far!!

get rid of the automation (for now) option 19 is persistent so get rid of it.

youre also using a local user in the broker…do you have that same username and password configured in the sonoff in tasmota for mqtt?

what does the log for mqtt broker show? (down the bottom of the addon page and refresh it)

1 Like

Hi David
username / password configured properly (yes added user in hass as mqtt)
I rebooted HASS after updating the sonoff pows to 2.5.0 and they are showing up via mqtt… yay.

Still have the initial problem off them timing out / being very flakey :frowning:

So that’s a Tasmota issue then? Which firmware/core?


Screenshot Above of Tasmo Admin
They were all flashed initially with the 2.4.2 core (http://thehackbox.org/tasmota/sonoff.bin)… all where rock solid except the POWS, they were intermittent at best.
After your advice David I flashed the POWS with 2.5.0. core(http://thehackbox.org/tasmota/020500/sonoff.bin) and have been better but still drop out through MQTT sometimes, they randomly show up as unavailable.

Because of this I have swapped them all out for basic ones to be more reliable.

Is anyone else using a big mix or Sonoffs and have a similar problem? Should I try the 2.3.0?