Sonoff T1 - Beep then double beep and turns on

Tags: #<Tag:0x00007f3f1b4ee038> #<Tag:0x00007f3f1b4ede08>

Hi

I currently have about 10 sonoff T1 devices installed and flashed with Tasmota 6.5.0

I am running the latest version of HA and Mosquitto mqtt. How ever randomly the devices will beep once and then beep again and then power on.

I have tried core 2.3.2 and 2.4.0 along the Tasmota 6.3 thought to 6.5 but issue continues.

Please help I am not sure what to do next. Logs on the device and mqtt show nothing out the ordinary.

In my Switch.yaml I use retain: false and follow the setup of the sonoff device following this tutorial - https://youtu.be/31IyfM1gygo

image|281x500

I have the same experience with my two T1 switches. So far, I did not find any solution…
What is funny, these two are located also in my main bathroom :slight_smile:

did you find a solution to this problem?
I too have the same problem with my T1 sonoff

The only solution for me was to pull out the switches and not use them.

I tried all sorts of changes:

  • adding spaces between the glass case and main case
  • flushing with all sorts of versions of Tasmota and combinations and core versions.
  • setting button rebound etc…
  • cutting the RF receiver to eliminate mates RF interference

Sadly Nothing worked. The panels are buttons are just to sensitive. End result was to remove them all and not use them at all. If you ever find a solution that doesn’t require soldering and changing out parts on the board please let me know. Best of luck.

I do not have solution however there is possibility to workaround. You can use Httas with following configuration:

switch:
  - platform: httas  
    switches:
      socket:
        ip_address: 192.168.x.xx
        friendly_name: Bathroom
        follow_device: false  

Follow device as false means that it will ignore current state of Sonoff and push it back to the state of the switch. Of course you will lost possibility to switch on/off Sonoff manuallly.

I’m haivng the same problem with my T1 3 gang.
1 beep, then followed by 2 beeps. Then switch 2 turns on.

I’m pretty sure it’s not ghost switching

It’s as if it’s going into pairing mode

Yip. All of mine did it. It’s cause the touch plate is too sensitive causing it it beep , then double beep(pairing mode) and then switches on.

I pulled all of mine out and have replaced with Phillips hue.
No fix. It’s a shame as it’s nice looking and cheap.

Guess you get what you pay for.

Same thing here.

Anything new to try?

Has someone tried the new Sonoff wall switches?? https://www.itead.cc/sonoff-tx-series-wifi-smart-wall-switches.html

Thanks!

xref: https://support.itead.cc/support/discussions/topics/11000025142