Sonoff Tasmota RF bridge won't reconnect to wifi

I run Tasmota on a Sonoff RF Bridge. It’s been working fine for a few years, but recently dropped off the wifi network and I can’t get it to reconnect. The blue LED is flashing steadily, once per second. I’ve tried pressing the reset button for 5, 10, 15 seconds but it has no effect. I did n notice the orange LED flash a few times (as well as the blue LED), but it only persisted for a few seconds.
I’ve tried rebooting my router but it didn’t help.
Any ideas for how I can revive it?

Not a big help, maybe attach the ftdi- adapter again and see what the serial console gives .

Ah…I no longer have it!

Might be difficult, but Tasmota devices can normally be reset by powering them on and off 7 times in rapid succession.
If successful, it should broadcast a Tasmota access point again.

1 Like

Thanks. I’ve just tried that a few times but didn’t have any luck.

Since posting my original message one of my other Sonoff devices has acquired the same problem - Sonoff Zigbee Bridge (also running Tasmota). It dropped off the wifi network and will not reconnect. It did reconnect for a while last night (without any intervention from me), but this morning it remains disconnected.

???

I’ve also just noticed that this pair of messages is appearing repeatedly in my router logs:

May 22 10:49:16 DD-WRT daemon.info dnsmasq-dhcp[4571]: DHCPDISCOVER(br0) d0:05:2a:22:22:22
May 22 10:49:16 DD-WRT daemon.info dnsmasq-dhcp[4571]: DHCPOFFER(br0) 192.168.1.47 d0:05:2a:22:22:22

The MAC address does not correspond to either of the two problem Sonoff devices, and is not one that I recognise from any of my other devices.
???

Experia WiFi ?

??
I’ve never heard of Experia wifi

Then it is not that. Mac-address that start with d0:05:2a are from the company that makes the Experia Wifi (common in the Netherlands as it is the box a big ISP provides)

I just checked the log again, and that MAC address finally seems to have disappeared. There are now repeated DHCPREQUEST/DHCPACK/DHCPDISCOVER entries for a couple of new MAC addresses (a new entry every 5-7 seconds), but I guess this is probably normal behaviour for a router in a suburban location?

I have now managed to fix the Sonoff Zigbee Bridge, by power cycling a couple of of BT Whole Home Wifi discs. It didn’t help with the Sonoff RF Bridge though - it still won’t connect.

Some of my ESP devices have another MAC address than the normal one when booking in a programmable mode.

When I ran Tasmota on them I had to first flash a basic firmware, then reboot on that firmwar before the new fianl firmware could be flashed.
TheTasmota flasher was supposed to handle this, but failed often, so I flashed manually each step.

The Tasmota firmware might have gotten bigger with some update, so you now need to flash this basic firmware as an intermediatary step, which was not necessary earlier.