Sonos cannot reach home assistant, firewall says packages can flow

Hi everyone!

I’m having a hard time setting up my systems to work across vlans. As far as I can tell, I did everything right, but still there are some issues.

Right now, I can send commands to my Sonos speakers, and they are executed (i.e: start playing a song). However, status updates never reach home assistant. On boot, I get the warning saying that sonos cannot reach home assistant so we’re falling back to polling.

My sonos is on vlan 30 with IP 10.10.30.20
Home assistant is on vlan 20 with IP 10.10.20.18

I’ve setup the firewall to allow all TCP and UDP traffic between these two addresses. On top of that, I’ve added a multicast proxy to my OPNSense firewall that should proxy all the discovery traffic.

I can see in the logs that sonos is trying to send updates to home assistant:

The Sonos app on my phone (vlan 20) does get all status updates as I expect.

I also included the manual network configuration as mentioned in the Sonos docs:

sonos:
  media_player:
    hosts:
      - 10.10.30.20
    advertise_addr: 10.10.20.18

I don’t understand what’s causing this issue. Shouldn’t the current config be enough to let sonos and home assistant communicate correctly?

Looks like the firewall is allowing the callback messages through. Are you by chance running HA in a container and not using host networking mode?

That could be the case. I’m using the TrueNAS Scale app and it doesn’t give me an option to change the networking mode I think. I’ve looked at the truecharts variant but couldn’t get that one to start on the nas.

I’ll look into the docker options some more later today and see if I can make it use host networking somehow.

I tried to find out the networking mode but am having a hard time figuring it out. I used the default home assistant image available on TrueNAS SCALE.

I did assign a static IP address to the container that I can successfully use to connect to port 8123. I thought that simply advertising that address in the sonos config would be enough to be able to connect but apparently not.

Do you know of some additional config that might be needed to make home assistant be connectable on that port?

I’m not familiar with how TrueNAS SCALE operates. Is it a container or KVM instance? Did you have to open port 8123 to allow browser connections?

It’s running as a container, I think there’s kubernetes involved but I’m not 100% sure.

I didn’t open any ports for 8123 to work. I assigned the container a static IP and so port 8123 just works there.