Sonos source list emty

Suddenly my Sonos source list is emty. I have tried to downgrade from 91.1 to 90.2 but no change. I don´t know if it could be related to a recent Sonos firmware upgrade.
Anyone else experienced this, and maybe knows what to do?

Hi. I’m on 0.83.2 and my Sonos integration stopped working this morning after the update to Sonos. I tried removing Sonos from Home Assistant, as it said that it couldn’t find the enitites. Now I can’t readd them, HA finds no Sonos devices :frowning:

So; probably not related to new HA, but to new Sonos-firmware.

I’m on Sonos 10.1 and HA .91 and Sonos is working fine.

strange then…And you have your source list with the sources from My Sonos visible in HA?
I have tried to remove the sonos integration i HA, reboot and then do the integration again… no change.

They all appear to be there.

no matter what I try I don´t get any source list in HA

I’m on 0.85.1 and Sonos has stopped working since the update the other night. Probably a Sonos related issue, I’m going to try upgrading to the latest HA version.

Same here.

Sonos 10.1 (Build 49263270)
HA 0.89.2

same here - no source list and can’t select sources from previously working scripts. on Sonos 10.1 and HA 91.1

Same here, also not workng after upgrading sonos.

same here running sonos 10.1 and HA 0.90.2 - only linein is available in sources

just updated to 0.91.1 and still same issue - source list is reduced to linein.

Same issue here. Source list is empty.
This must be resolved!

Källa = Source. Cant press the dropdown menu.

Using: Hassio 0.90.2 and Sonos 10.1 Build 49263270

Yes lets hope someone here knows what can be done.

The empty source list issue was reported in GitHub issue 22714. I will only participate in the discussion there (I am the maintainer of the Sonos integration, for the time being).

Sonos 10.1 not working with pre-0.86 is a different issue, solved in PR 20196.

I removed the unwanted favourites from my Sonos and the source list is back :slight_smile:

I also removed a new favorite from my sonos that I didnt put there. It was a Spotify favorite.

Its working again.

I disabled the newly introduced “recently played” feature and all my sonos features came back to Homeassistant.

I too am having problems.

Previously I had a working automation with one (of many) actions;

  action:
- service: media_player.sonos_join
  data:
    master: media_player.kitchen
  entity_id:
    - media_player.kitchen
    - media_player.tv
- service: media_player.select_source
  data:
    entity_id: media_player.kitchen
    source: "BBC Radio 4"        
- service: media_player.volume_set
  data_template:
    entity_id:
      - media_player.kitchen
      - media_player.tv
    volume_level: '0.35'
- service: media_player.media_play
  entity_id: media_player.kitchen

This stopped working a few days ago. Now it will play the speakers, but not change the source. I have had look at HA states and it looks as though the attributes naming has changed from source to media_title.

volume_level: 0.35
is_volume_muted: false
media_content_type: music
media_title: BBC Radio 2
media_artist: Steve Wright’s Big Guests
source_list: 
shuffle: false
sonos_group: media_player.kitchen,media_player.tv
friendly_name: Kitchen
entity_picture: /api/media_player_proxy/media_player.kitchen?token=62297120e927b97e9102a664ad08fdbf4437dc850f020d8b117ee3ed0abd7f53&cache=b6fc2a045953f266
supported_features: 64063

My idea was to change the action from

  - service: media_player.select_source
      data:
        entity_id: media_player.kitchen
        source: "BBC Radio 4"

to

 - service: media_player.select_source
      data:
        entity_id: media_player.kitchen
        media_title: "BBC Radio 4"

but that doesn’t work.

Does anyone have any working automations that inclde selecting a source for Sonos to play? @amelchio has the syntax changed?

Thanks

try to follow some of the solutions for getting back the source list in GitHub issue 22714.