"Sorry, it looks like [my google app] is unavailable right now" - can't reconnect Google account

Tags: #<Tag:0x00007f32668b4620>

I set up Google Assistant integration a few years ago, following the instructions here to create and link an app on the Google/Firebase platform:

The integration has been working fine until the last few days, but now I get the error message above when I try to trigger any Google Assistant commands for HA. I’m guessing there are 2 possible causes:

  1. I got an email 9 days ago from Google telling me that there were issues with the security rules on my Firebase realtime database, and that my database would be deactivated unless it receives traffic or I update my security rules (I have just updated my security rules). The 14 days has not yet passed.
    or
  2. I recently changed my Google password.

So I’ve gone into the Home Control section of the Google Home app on my phone and tried to re-connect my Google account, but keep getting this message: “Couldn’t update the setting. Check your connection”.
Any ideas for how I can restore access to my Google app and get my HA Google Assistant integration back up and running?

I’ve got the same issue. Did you resolve this?

Edit: Fixed it… turns out I blocked Google on my firewall… whoops.