SpeedTest not working after update to 2021.0.4

After update Today (Core to core-2021.4.0 and HA OS to 5.13, running in VBox) the SpeedTest integration does not work.

SpeedTest error:

2021-04-08 18:41:19 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry SpeedTest for speedtestdotnet
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 249, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/speedtestdotnet/__init__.py", line 75, in async_setup_entry
    await coordinator.async_setup()
  File "/usr/src/homeassistant/homeassistant/components/speedtestdotnet/__init__.py", line 194, in async_setup
    self.api = await self.hass.async_add_executor_job(speedtest.Speedtest)
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.8/site-packages/speedtest.py", line 1091, in __init__
    self.get_config()
  File "/usr/local/lib/python3.8/site-packages/speedtest.py", line 1173, in get_config
    ignore_servers = list(
ValueError: invalid literal for int() with base 10: ''

I haven’t done the update. Yet my speedtest intergration is also not working. Wonder if this is update caused or simply a coincidence

There are many other posts that it stopped working.

I got the same error. It looks to be a known issue with the speedtest cli. Looks like the HA devs already fixed it though and have a merged PR, so hopefully should see the HA update in a day or so (if not sooner). :crossed_fingers: :grin:

1 Like