Starting from scratch not working

I’m trying to start from scratch with my ESP32. Here is what I have tried:

  • Reset the ESP32: boot button press, rst button press and release, boot button release
  • Install the default configuration via USB
  • Reset power to the ESP
  • Try to install via OTA

I get: ERROR Error auth result: Error: Authentication invalid. Is the password correct?

Where do you see this?

It’s in the log that displays when trying to install via ota.

Looks like you got the ota password wrong.

Right. But how do I get it right? How do I reset it? On my other ESPs the password was generated when I did the initial install via USB, and I simply kept it for OTA updates. This one also generates a password with I add it as a NEW DEVICE, but it doesn’t work when I try an OTA update. So I’d like to wipe the slate clean and start from scratch, unless there is some other way to set a password that works.

Right after I wrote that, I tried once again by holding down the boot button while applying power. This time it worked. Cheers.

1 Like

You flashed via serial and that doesn’t require authentication unlike the ota update you tried before

Correct. I flashed via serial and subsequently I was able to flash OTA. Whereas previously, I had flashed via serial and subsequently I was unable to flash OTA. All good now.