Steps sensor not working

I enabled the steps sensor a while ago. I would like to create a private health tracker.

After enabling it worked well for a couple of days and then it stopped working or only reports a few steps. Sometimes a reboot of the phone works but mostly it doesn’t. Any other sensor is updating fine.

By example, I walked 5 km this morning and only one step was counted. In de last five days the most was counted thursday: 13 steps.
The activity sensor detects walking

App 2023.10.2-full
Phone Samsung S22 Android 13

try to install google fit app on the phone. It activates my sensor to work. Give it a try.

Will give it a go, but my goal is to say goodby to the Google apps…

you can delete it after.

The app relies on the devices API to tell us how many steps were taken. Nothing the app can do if that’s the value you got. Try the Google fit trick that may help

Installing Google Fit indeed fixed it. I will monitor this for a couple of days and then delete it again to see if it keeps working.

1 Like

It lasted for three days. Fit still counts steps but HA doesn’t.