Stop DuckDNS without supervisor access

I recently set up DuckDNS on my pi to allow me to externally access it, and it’s been working fine, except for the fact that the supervisor will not load, see this post. I’d like to install NGINX so I can access it locally as well as remotely, which should let me access the supervisor locally, but to do that I need access to the supervisor, which I don’t have. So I was wondering whether there’s any way to stop the DuckDNS add-on, so the pi is once again available at homeassistant.local, without the supervisor. I could then also take a look at the full logs and see what’s happening when I tried to access supervisor and why it wasn’t working. Any help would be great, thanks!

Would calling it to stop through developer tools somehow work?

can you use local_ip:8123 instead of homeassistant.local and access supervisor that way?

The only way I can access it it through my duckDNS domain with the port on the end. Both the internal or external IP addresses, both with and without the port, don’t work. It is pingable on the internal IP, but it doesn’t work if you try to connect to it through a browser .Homeassistant.local:8123 also definitely doesn’t work

Have you played with the ssl settings under http: in configuration.yaml? If so comment those lines out.

I don’t think I have, and since the add-on I use for editing my configuration.yaml can only accessed through the supervisor I can’t edit it anyway

In developer tools I was able to find a service that can be called, which looks like it should be able to stop the add-on. However, I’m not sure whether this would again allow the Pi to be locally accessible as if I had never set up remote access and DuckDNS, or if it would just make the Pi unreachable.

The DuckDNS add-on does 2 things;

  1. Updates your DuckDNS subdomain record with your current external IP
  2. If you enabled it, it will generate SSL certificates.

So since the add-on does not handle traffic (how you access it), stopping it will not do anything, other than stop the updates to the subdonain record and certificates.

DuckDNS is really “just” a “phonebook” that maps names to IP addresses.

You are using one of the following, and should be looking there instead;

  • A proxy server (like NGINX)
  • Port forwarding directly to homeassistant (check your router)
  • Port forwarding directly to homeassistant with certificates configured for the http integration (check your router and your http configuration)
  • Some other strange way of accessing

For all of them, you can reach homeassistant locally with IP as @DavidFW1960 mentioned
If you used option 3 (with changing the http integration) you still need to use https and not http with the IP and use port 8123, and accept the certificate error/warning the browser will give you

1 Like

Thanks! I was able to access it locally by using it IP with the port on the end, as well as https:// before, which I didn’t realise I needed.

Update: I tried again today and was unable to access it. I used exactly the same address as I used the other day, which worked then, but it isn’t working now. It’s also not externally accessible. On the Pi itself there are no lights on in the ethernet port, which are always on normally. The other lights on the Pi are working, so it’s definitely on. I tried switching it on and off which didn’t help, as well as unplugging and plugging back in the ethernet cable. I only accessed it briefly the other day to update it, I told it to create a snapshot and confirmed, then closed the tab once I saw the snapshot being created. I meant to log in later, but forgot and when I tried to today It wasn’t working. Any ideas / is there other ways to access the Pi if its not connected to the network?

Turns out after the update my mesh wifi network (which I had my pi plugged in to) blocked HomeAssistant. I plugged it directly into my router and it works