Strange duckdns problem

I have a strange duckdns problem. A few weeks ago, my SSL certificates reached 90 days. Around that time, my domain stopped working. It shows the home assistant logo with a password field and underneath it the text “Unable to connect”. After entering my password, a processing circle appears whereafter it just returns to the same screen.

The port forwarding is correct because it used to work and I didn’t change anything. Also, the non-secure http works, even from outside the network. Any ideas?

Try using incognito mode in your browser. The logo/login will show up just based on cache information.

I would check duckdns status to ensure it is being properly updated, also did you renew your SSL cert?

I tried incognito (https), it shows the login and then it goes to the http version with strikethrough of https in the address bar.

How do I check the duckdns status and renew the certificates? I am pretty new at this.

Likely it’s your expired certificate. Looks like duckdns is working as you got to your front end login.

Just so you know how to do it. Search ‘what’s my IP’ Google should give you the result directly, other search engines may require you to click into a link to check it. Any option works.

Login to your duckdns account and confirm the IP for your domain matches the one you looked up earlier. This is all duckdns does, keep track of your IP and send your domain to that address.

For the certificate renewal, what instructions did you use to set up your certificate? Also, what’s your install method? ( docker, hassOS, or hassbian, etc.)

I am running I checked my ip and checked that it is the correct ip on they are the same. I figured as much because the non-secure http works. Regarding the certificate: I didn’t do anything other than install and set up the duckdns add-on in

Does hassOS automatically renew certs at their expiration date?