Strange LOG output

Hi All!

I installed HASS to both my Synology Station and Raspberry Pi (yeah… I like comparing performance and error logs :slight_smile: )

And i bumped on to this error:
17-02-24 16:26:41 ERROR (Thread-13) [netdisco.ssdp] Error fetching description at http://192.168.1.200:49152/wps_device.xml
17-02-24 16:27:18 ERROR (Thread-4) [pywemo.ssdp] Error fetching description at http://192.168.1.200:49152/wps_device.xml

Yes, I have WEMO devices in my network.

The strange part is : my local network is sitting on 192.168.178.x, yet HASS is trying to fetch description from 192.168.1.200. Both my Synology and RPi exhibits this problem.

All seems to be working ok though, I have the Wemo switches on my HASS Panel.

Did I miss something?

Cheers
Erick

That’s just discovery trying to determine the setup of anything it finds.

Next release will allow you to allow discovery to ignore things so you’ll be able to turn those off. Right now you can ignore the ‘errors’ though.

I guess my point here is that… the 192.168.1.200 could be a hard coded address.

Hence, from a scanning point of view, it is wrongly looking in 192.168.1.x network, rather than detecting my subnet and scanning 192.168.178.x instead.

(*I’m only guessing though)

cheers!
Erick

Hi.
I have got a similar error though mine is a different subnet :-`
2017-11-09 01:42:00 WARNING (SyncWorker_7) [netdisco.ssdp] Error fetching description at http://192.168.0.254:49152/wps_device.xml
And again my class C is NOT on 192.168.0.0
If this is part of discovery then it’s wasting time checking addresses that don’t exist and would have been advised as not being part of local LAN when it signed up under DHCP
I’m running Hass.IO Home Assistant 0.57.2
Mutt

I have to agree here. Doesnt look like its been solved in the lastest as well. Why would it scan outside my subnet?

The same error over here
Error fetching description at http://192.168.0.254:49152/wps_device.xml
Did you find anything to solve this?
Running Home Assistant on RPi, my subnet is 192.168.1.x
Regards,
Gerben