Stream Component: Confirmed Cameras and Configurations

yea on my raspberry pi it takes about 10-12 minutes to install pyAV while on faster hardware it takes 2-3 minutes…just like when zwave gets an update some components just take longer to install. Start up errors usually show up in the log.

Going back to my earlier comment is no one else having a similar issue as me where when you launch the stream it fails to load anything but a black spinning window. However if you close it and launch it a second time the stream starts as it should?

Just curious if there are timeout settings or anything I should tweak or if this is worthy of opening as a bug on github.

currently testing with at reolink camera setup directly as a generic camera using the listed known config. The playback issue seems to happen on chrome/windows 10, iOS and apple TV as playback devices.

Thank You, that looks to have worked. I just need to actually get it to stream to echo show now

1 Like

How long are you leaving the player up before closing it? It can take up to 20 seconds or so for the stream to start. Once it starts teh stream is kept open for 5 minutes which is probably why you see it working the next time around.

Has anyone tried this with a Yi Camera? if not I’ll give it a shot

Hey, you should add this configuration too for the low quality setting in reolink. Reolinks have 2 quality settings, low and high.

High quality (one you posted):

- platform: generic
  still_image_url: "http://192.168.1.x/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=wuuPhkmUCeI9WG7C&user=user&password=password"
  stream_source: "rtsp://user:[email protected]:554/h264Preview_01_main"

Low quality

- platform: generic
  still_image_url: "http://192.168.1.x/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=wuuPhkmUCeI9WG7C&user=user&password=password"
  stream_source: "rtsp://user:[email protected]:554/h264Preview_01_sub"
1 Like

I have been trying on Alexa devices and Samsung TV s without anything.
Is everyone doing it from services wit camera.play_stream?
Any guidance on how to even get it to work on chrome would great

Do you need to do anything special if your blue iris server is behind a NGINX proxy? I can’t get the stream using the domain name.

I do not have it behind NGINX but you want to make sure the URL is accessible, try it in VLC to see if its valid. May need to make sure the directories are being forwarded properly?

Not every device can play the stream, I think only cast devices have been confirmed as of now.

@petro

I have tried both the main and sub stream

@dshokouhi

When you turn on stream and enable a stream on a camera, the web UI forces you to use the new stream method… When I click on my camera now in google chrome it launches a video player widget instead of the web window slide show.

It works really neat but I don’t have any audio (RTSP stream from Synology). Is this supported?

It looks like it works in VLC although it takes a bit to load up. Maybe there is just something goofy in the settings or its a bit much for the Raspberry Pi to push through? I’m not sure how streams work but I would assume its all going through the Pi’s hardware at some point

No audio yet

1 Like

Hello everyone,

first of all I want to thank you for this component that works wonderfully since the transition to HA 0.90.1.

it streams the video from Synology and it’s ok with VLC.

However, I want to send the video to my openlec / kodi without success.

I read on the kodi forum that m3u8 format was not supported.

Si i have “edited” hls.py that it generates a m3u file instead of m3u8 and it works but only 1 or 2 seconds.

Do you have this problem too? If so, what is the solution for reading a m3u8 file?

In advance thank you for your help!

RTSP URL’s for my XMEYE AHD cameras connected to a DVR with IP 192.168.1.10:

rtsp://192.168.1.10/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp

change the ip and channel according with the ip of the DVR and the number of the connected camera the stream component works pretty well ( some artefact but it’s ok) i cant’ find the still image url: can someone help me?
could be possible reduce the size of the streaming ? ( for example 640 x 480)

Hi,

I’m using a Foscam cam model FI9853EP (which does not appear on ispyconnect list). But I have the rtsp link that allows to open the live stream in VLC, it follows this pattern: rtsp://user:[email protected]:port/videoMain.
When I try to open the stream, I have the following error: ERROR (stream_worker) [libav.rtsp] method DESCRIBE failed: 401 Unauthorized. I tried removing the username and password from the url and setting them in the conf file with the same result.
Any idea how I can fix that?
Thanks.

Confirmed working. User and password in plain text. Not base64

Dahua DH-SD22204T-GN
Firmware: 2.622.0000000.3.R.T4.484

- platform: generic
  still_image_url: "http://192.168.1.XXX/cgi-bin/snapshot.cgi"
  stream_source: !secret stream
  username: user
  password: !secret dahuapw
  verify_ssl: false
  authentication: digest

Since the stream link has to have user and pw hardcoded, I put the link in secret.yaml:

stream: rtsp://user:[email protected]:554/cam/realmonitor?channel=1&subtype=00

This sounds like your username and password are wrong for accessing the stream.

Thanks @hunterjm for answering. Yes, it looks like but either following configurations give the same behavior while opening the url in VLC works.
Conf1:

camera:
  - platform: generic
    stream_source: rtsp://user:[email protected]:88/videoMain
    still_image_url: http://192.168.1.153:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=user&pwd=pass
    name: Entrée

Conf2:

camera:
  - platform: generic
    stream_source: rtsp://192.168.1.153:88/videoMain
    still_image_url: http://192.168.1.153:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=user&pwd=pass
    name: Entrée
    username: user
    password: pass

Is there any way to test?
Thanks.