Stuck at INFO:homeassistant.core:Timer:starting


#1

I have used AIO to setup Home Assistant in Raspbian Jessie. When I launch ‘hass’, it get stuck at this step: INFO:homeassistant.core:Timer:starting. However, there are no issues while launching in demo mode ‘hass --demo-mode’.

(homeassistant_venv) [email protected]:/home/pi$ hass --version 0.43.2

(homeassistant_venv) [email protected]:/home/pi$ hass --debug
Config directory: /home/homeassistant/.homeassistant
WARNING:homeassistant.config:Incomplete core config. Auto detected time_zone: America/New_York
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=turn_off, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=turn_on, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=toggle, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=stop, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=restart, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=check_config, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=reload_core_config, domain=homeassistant>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=create, domain=persistent_notification>
INFO:homeassistant.bootstrap:Home Assistant core initialized
INFO:homeassistant.loader:Loaded mqtt from homeassistant.components.mqtt
INFO:homeassistant.loader:Loaded logger from homeassistant.components.logger
INFO:homeassistant.setup:Setting up logger
INFO:homeassistant.setup:Setting up mqtt
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=publish, domain=mqtt>
INFO:homeassistant.core:Bus:Handling <Event component_loaded[L]: component=mqtt>
INFO:homeassistant.core:Bus:Handling <Event service_registered[L]: service=set_level, domain=logger>
INFO:homeassistant.core:Bus:Handling <Event component_loaded[L]: component=logger>
INFO:homeassistant.bootstrap:Home Assistant initialized in 4.16s
INFO:homeassistant.core:Starting Home Assistant core loop
INFO:homeassistant.core:Starting Home Assistant
INFO:homeassistant.core:Bus:Handling <Event homeassistant_start[L]>
INFO:homeassistant.core:Timer:starting

Thank you for your help in advance.


#2

I am running into the same issue as you today using the home assistant instructions for python virtual environments found here:

I get:

INFO (MainThread) [homeassistant.core] Timer:starting

>hass --version
>0.71.0

I altered from the instructions in that my user, folder, and environment are not homeassistant but some other name.

Were you able to resolve your timer issue, and if so, how?

c


#3

I am having the same issue - anyone resolve this?


#4

I think the issue was configuration.yaml was partially updated. If I deleted the configuration.yaml file and then reinstalled hass.


#5

Having the same problem, after trying to switch to docker for running homeassistant.

Here’s my docker-compose.yml:

version: ‘3’

services:
  homeassistant:
    container_name: hass
    image: homeassistant/home-assistant
    network_mode: host
    volumes:
      - ./config:/config
    restart: always

I spun-up the container before making any changes to configuration.yaml just to see if it would work – and it did. Then I spun-down, deleted and re-ran docker-compose up and the hass container sticks at Timer:starting.

I’ve deleted the old configruation.yaml (that was created when I first spun-up the hass container) and tried everything again and again. Can’t even get back to it working at all.

Any ideas?


#6

I’m also stuck at this point as well. Did a fresh install, still stuck. Deleted configuration. I’ve tried on multiple computers, reinstalled python, tried with with docker and python. I’ve had zero luck. I still can’t even get it to start. If I hadn’t already had some experience with this system, I’d likely have give up by now. Any ideas?

Update: Solved by doing a fresh windows install.


#7

Not sure if this is the case for you, but I was running docker on macOS. Come to find out, and for reasons I only barely understand, you can’t use “network_mode: host” as it doesn’t work correctly with Docker for Mac. I switched to a Linux machine and used the same docker-compose.yml script and it worked.