Stuck on kickstart-bk7231t

Gosung Wall Switch.
Using tuya cutter, I was able to install ESP Home kickstart but forgot to run the LTChiptool when I was connected to. I tried connecting to my Wifi. It won’t…
Now it does not have an ip address (in Fing it shows as In Range)
How do I physically reset the switch so it broadcasts kickstart-bk7231t again?
Tried holding the switch down a long time, nothing… Turned power off and on again.
Still shows in HA Screenshot 2023-09-11 082318

Ideas?

did you add captive_portal to it?
if so you should see an accesspoint.

it can also be that your devices is working, it shows kickstart always, even when asting for the api key.
but in the last step the device suddenly can have the new name, just try to configure it.

I am having the same problem here.

Broken into my Tuya device. Then signed into AP portal. I then gave it my wireless network details and it has connected there.

No matter what I do I can not get it to accept my firmware made in esphome. It uploads the file and then says “Update Successful”. But it reboots and it is stuck on old firmware.

It worked for my first device but not for second. I have changed all the ota and api keys as usual.

Any ideas appreciated.

Turned the device off for at least 5mins in frustration instead of ~15 seconds and on boot it was running the uploaded firmware. Yay!