Stuck on SSD Hassos installation (Pi4), boot partition seems too small

Well here is a noob question / issue: I followed a tutorial installing HA on a SSD, connected to the RaspberryPi4.
So far so good, but when I power the Pi and go to homeassistant.local, I see in the log that it is stuck at “Error on Home Assistant installation. Retry in 30 sec”. I’ve first looked at the initialize screen for hours… According to some research this could be happening with a lag of storage. This could not really be the case, because I use a 128gb SSD ;).
Anyways, connected the SSD to the computer and noticed that the boot partition is only 32mb. The rest of the SSD is unassigned. Could this be the problem? And any idea what I have messed up?
Thanks all in advantage :smiley:

So the steps are:

  1. Write the SSD with the rPi4 HA image (using Balena etcher or similar)
  2. Make sure your Pi will boot from USB (as per the Pi site)
  3. Remove any SD card
  4. Plug SSD into Pi and boot
  5. Wait a fair while - the initial setup includes extending that small partition to be the size of your SSD. That takes a while.
2 Likes

Thanks for your quick reply! Those are exactly the same steps as described in the tutorial.
The only step I couldn’t verify was step 2. I took this step, but I am not sure if it was successfully.
And I waited for step 5 for hours, but it still kept repeating error on HA installation.

If you have removed your SD card and you are getting console messages then you have booted from USB.

The only thing I can suggest is try booting from a USB 2 port - some SSD enclosures have problems with the Pi USB 3 ports.

I was checking the rest of the config and I am also not sure about the way the SSD was formatted. It is formatted as FAT, is that right?
And I also have the option to “convert disk to dynamic disk” not a clue what that is :stuck_out_tongue:

No it doesn’t matter. When you write the image to it - if you are doing it properly, you are overwriting whatever the disk is formatted as.

Problem is solved! I formated the SSD as ntfs and followed all the instructions again. This time it boots and it is working! Thanks for the help.

I (rather new at Home Assistant and Raspberry Pi) should have read this sooner and better. Thanks for sharing.

I tried Balena Etcher a few times, and the Raspberry Pi Imager tool (which has Home Assistant in its menu, learned this as well in the process), every time getting a 32MB partition. Even when my file system was NTFS. I learned in the process that Windows has a little program called “Disk Manager” with which I was able to remove all partitions and try again, and again… but what I should have done was to read your 5th step with “…the initial setup includes extending that small partition…”! I did miss that piece of information in several tutorials.