Supervised install of old version

I currently run under HassOs on HA 2022.7.1. I find myself in what appears to be a situation from which I can find no way forward with HA.
I cannot upgrade to the latest version of Home Assistant due the breaking change for bluetooth trackers (my automations rely heavily on them), so I cannot go higher than 2022.7.1. A second issue I have is I wish to install something called hiksink, which requires the Rust compiler, which I do not think can be installed on HassOs. Hiksink can run under docker, and it is possible to install HA 2022.7.1 as a docker container, HOWEVER, if I do that, I cannot use HA addons and I need to use mosquitto, samba backup, duckdns and a few others. So the only option left is, I believe a supervised install, the problem is that this does not give you the option of anything but the current version of HA.
Is there any way I can get the supervised install to use 2202.7.1 rather than the latest version?
If not, I may be facing having to move to another automation platform and lose the many hundreds of hours I have spent building my automations and dancing around the continual stream of breaking changes in HA :frowning:
I would appreciate any help you may be able to give to circumvent these problems.
Many Thanks

Those exists as “normal” containers (by opposition to add-on).
If you know your way around eg. debian and docker, it is fairly simple to get HA running with his “friends” as containers and not add-on.
So, instead of supervised go for Home Assistant Container and you can install any HA version you want. They are all on docker hub.

Greengolfer - thanks, I have tinkered with debain and docker, but class myself as a newbie. Having poked around a little, I THINK I can just create my own copy of a file called ‘stable.json’, to point to version 2022.7.1 and point the supervised install script at my version of stable.json. I will try to give it a go tomorrow and see if it works. I would much rather be able to use add-ons for the simplicity of maintenance.

In the cli enter

ha core update --version 2022.7.1

Or just restore a backup you have with that version.

I must be missing something here, nothing forces you to run the latest version of core. If you updated and something broke, rollback.

Thanks for that, it worked. I am in the process of restoring from a backup, so hopefully will soon be able to achieve the result I wan

I am still having issues. Managed to get back to version 2022.7.1 and tried to restore a backup taken from my HassOs installation. After a couple of hours it has still not finished but I can use another browser incidence to go to the overiew page, showing that HA has restarted, but it has not restored any of my add-ons. This is an issue because I want to use the Traccar add-on, but the latest version is not available on HA 2022.7.1 and again, I can see no way of installing an old version of an add-on, unless someone can tell me differently.
I could of course run Traccar in its own docker container, but I wanted to retain the integration with HA.

I started over, installing Raspberry Pi OS 32 bit, then following the instructions for doing a supervised install here. When HA started, at the onboarding panel, I restored the full backup I made from my previous HassOS installation.
Once I could connect again, I had HA 2202.7.1 and all of my add-ons were installed. However none of them were started and when I attempt to manually start them, I still receive a message when clicking on them in the sidebar that ‘Add-on is not running. Please start it first’.
Any suggestions as to how to fix this are most welcome.

Restarted HA and add-ons seemed to start. Only issue is 502 gateway error from TracCar, but I can access it via port 8072.

This isn’t a supported OS for a supervised install so I imagine you will run into a number of challenges along the way.

Ok, I installed Debian 11. Home Assistant exhibited EXACTLY the same behaviour as when installed on Rasbian.