Supervisor page load fails on fresh Home Assistant OS install on Raspberry Pi 2 B

I’m testing a fresh install of Home Assistant OS on Raspberry Pi 2 B. For some reason the Supervisor page on the web UI does not render. This is hard to describe, but the browser tries to load upper navigation strip and spinner rolls for a split second, only to end up as a blank page.

When checking Web browser’s developer tools console, this message shows:

VM230 entrypoint.b954f17a.js:1431 Uncaught (in promise) TypeError: this.supervisor.localize is not a function
    at HTMLElement.value (VM219 entrypoint.b954f17a.js:1431)
    at HTMLElement.update (VM219 entrypoint.b954f17a.js:3936)
    at HTMLElement.performUpdate (VM219 entrypoint.b954f17a.js:3936)
    at HTMLElement._enqueueUpdate (VM219 entrypoint.b954f17a.js:3936)

Not necessarily relevant but could be connected to the problem.

Tried searching for problem, but landed on bunch of solved Github Issues. Other solutions involved ssh access, which is not AFAIK possible to achieve without Supervisor add-ons.

Tested web browsers: Firefox 86 (64-bit), Ungoogled Chromium (88.0.4324.182)
Home Assistant version: 2021.2.3
Home Assistant OS 5.12
Frontend version: 20210127.7
Supervisor version: supervisor-2021.03.1