Support for Midea A/C

Not that I look you noob (I’m not), but do you have connection between your ESP and your wifi network? (check your router log and ensure that the ESP is connected).

Also, have a try with the recommended settings (ie no !secret yaml, enter the wifi password directly into the esphome yaml). Also: have you set password for homeassistant api? If so, then disable it until you’re 100% sure that it’s not the root cause.

You absolutely should! xD

It has to be connected to show the log, doesn’t it?! :thinking:
Also it shows up in my router’s device list, and it is online (green) in the ESPhome Addon

I’ll try that

EDIT: no change … still just

[10:55:55][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[10:55:56][D][midea_dongle:029]: RX: AA 22 AC 00 00 00 00 00 03 03 C0 01 4B 28 7F 7F 00 30 00 00 00 64 65 00 00 00 00 00 00 00 00 00 00 E7 1A 
[10:55:56][D][midea_ac:034]: RX: query frame
[10:55:56][D][midea_ac:072]: TX: query

over and over again

with switched RX/TX cables as well?

If I switch the cables it’s:

[11:05:16][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[11:05:17][D][midea_ac:072]: TX: query
[11:05:17][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[11:05:18][D][midea_ac:072]: TX: query
[11:05:18][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[11:05:19][D][midea_ac:072]: TX: query
[11:05:19][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[11:05:20][D][midea_ac:072]: TX: query

:frowning:

I think this one should be working. Try this: OTA update your device via ESPHome and check carefully your log. It should show that it’s connected to Home Assistant.

which one should be working? the one that only says:

[11:05:19][D][midea_dongle:094]: TX: AA 22 AC 00 00 00 00 00 03 03 41 00 00 FF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 84 68 
[11:05:20][D][midea_ac:072]: TX: query

?!

EDIT

it does connect to wifi and Home Assistant - that was never an issue afaik

the issue is, that it only sends these nonsensical strings of numbers - which HA can’t seem to do anything with

Wait! Have you set the climate card? There should be an entity on your entities list starting with climate and the name you set within ESPHome (for example. climate.WHATEVERYOURNAME).

You can put that entity as a card onto your dashboard and the magic happens :slight_smile:

I did
That’s what it looks like:

image

(it says “unavailable”)

:weary:

Then I’m out of ideas :frowning:

Then I’m out of ideas :frowning:

Or, one more thing: try the stable or beta version (not the dev - just noticed that you’re on the dev channel).

it’s so weird that it does correctly show the values in the logs, when I send a IR command

… so it partially does work

is it already in the stable version?! thought I needed the dev branch

Will try

It works now … I deletet everything from ESPhome and Home Assistant, re-flashed the ESP-01 and addet it again… I have absolutely no idea what is different now, since the configuration is exactly the same as before (except for the name)

I was just about to mention you should post the logs on the devs telegram channel, but it already works :yum:

And it used to be the devs branch, and it did take an awful long tome before the PullRequest was merged into the stable branch, but it is now, so you should use the stable branch😉

yeah - I figured as much xD

Another question - is there a way to control the swing position? on the IR remote I have a “direct” button which moves the swing a couple degrees each press. Can I do the same over wifi? or even better, can I send a “all the way up” or “all the way down” command? :thinking:

Hmm, I haven’t seen that option pass by yet.
Guess it differs from brand to brand.
Mine doesn’t have that option for sure.
Because of that i don’t think that functionality is supported (yet), as nobody reported it missing. :thinking:

So also here I suggest to join the telegram channel, where you can ask, provide the logs (and hope they find a solution)
Then maybe it will be supported in next release :yum:

air conditioner is controlled from home assitain in all modes.
does not display the current state :sleepy:


how can this be fixed?
platform: ESP32
board: nodemcu-32s

Do you got F (instead of C) working? I changed this:

    visual:
      min_temperature: 18 °C
      max_temperature: 25 °C
      temperature_step: 0.1 °C

Into this:

    visual:
      min_temperature: 70 °F
      max_temperature: 90 °F
      temperature_step: 0.5 °F

And the control panel went crazy - sticks to 70F if I click “up” nothing happens, if I click “down” I get something ridiculous like 125 etc (by one click).

AC follows panel settings, but only for normal range, like 70 - 80 (other I couldn’t reach per panel craziness).

EDIT: So, meanwhile I was waiting for response from you (5 minutes?) I checked how “C” works. And it works weirdly, to the sense that I achieved what I wanted - control and readings in F, using C in configuration. What… Nevermind. Works.

EDIT2: And big thanks to who ever wrote this, or had his inputs! I have been trying to reverse engineer this stuff for a while now, giving up like 3 times. And this is plug and play solution! Thanks!

Maybe a different model with unknown data?
Please ask on Telegram channel…
(as I am not really involved in the development, just monitoring and relaying usefull info)

It is indeed mostly plug and play…
But it does involve some hanydy work…
Glad it worked out :wink: