Support for Velbus Home Automation

hi Ceral2nd
these modules appear in the log:
module 1 = VMBGPOD
module 4 = VMBGP2
module 6 = VMBPIRC

these modules do not appear in the log:
VMB4RYNO, VMB4RYLD

I have now placed a velbus logger. with the following link you can view it:
log velbus

Best Regards
Yves

can you get me a full list of modules and there address?

and can you restart hass with debug log level enabled for the velbus component?

I have put this in the configurtion:


these components are used to date:
velbus

its the vmbpirc that is causing problems, this module is not (yet) supported in python-velbus.
if python-velbus finds an unsupported module its doing wierd things. it never lets HA know that its ready with scanning.

This is the reason you are not seeing any modules.
Will try to solve this in python-velbus

this is weird, i just added this module 2 days ago, i will remove it and start it up again

if it doesn’t help then i will need the full log, and not just a part of it. In that case it seems that not all channel names are received/requested by python-velbus so this is probably a bug in that area

module removed: Naamloos-1
link to the full log:
https://1drv.ms/u/s!AnIqLpusHNu0gv9De290ywRyyr6OiA?e=QOLbrB

we will need to add more debugging to the python-velbus lib to find out what is causing this.

can you add some debug prints to the python-velbus code?

controller.py after

def module_loaded():
logging.info('module_loaded')

and rerun the hass startup and get me the whole log

Hi

I want to do this, please tell me where I can find the python velbus code on Hass.io

i have no idea about hass.io
i never used it and can not help you there …

Hi

i have now installed home assistant on a raspberry with hassbian,
with the same result for velbus.here is the link to the log: https://1drv.ms/u/s!AnIqLpusHNu0gv9WXe41b_RRyhb5mQ?e=BqXzZq

this weekend I will try to add some debug prints to the python velbus code

today i was able to reproduce this here at home

its a timing problem in the python-velbus lib, will try to see if i can get this solved

Hi everyone. I ended up here cause i’m switching from openhab to home assistant and discovered that dimmers are not supported yet? Almost all of my lights are controlled by dimmers, so for now home assistant isn’t very usefull :slight_smile:

I’ve read that Cereal2nd was working on dimmers in sept. 2018, but nothing regarding dimmers after that. Was development stopped?

For me kind of the same situation (DomotiGa -> Home Assistant)
I’m happy to assist to add support for dimmer modules I have (VMBDE & VMBDC4 but do not have mutch experiance writing in Python so it will be a steep learning curve for me. Anyhow I already managed to do a PR to add support for the missing VMBRY4 module :smile:

the problem is that i don’t own any dimmers …
so its verry hard to implement this correctly without the possibility to test them out

Yeah I get that. I’m a developer myself and from time to time I need to do hardware interfacing and without an actual device things it’s just a shot in the dark.

As a web developer I have no real experience with Python (except for some minor modification in existing code), but I’m more than willing to help / test / debug / interpret the docs, … If you’re interested I would rather continue development discussions on Slack or something, it’s more efficient :slight_smile:

FYI, i have the following Velbus modules:

  • VMB6PBN
  • VMB8PBU
  • VMB8IR
  • VMBPIRM
  • VMBPIRC
  • VMB4DC
  • VMB2BLE
  • VMB4RYNO

Finally I had some time this weekend to get the pull request ready which allows to control the VMBDME and VMB4DC module types.
Next step: Get some time to add the “Light Entity” functionality to the Velbus integration code so we can finally control them from Home Assistant :grinning:

I’ve light control (on/off & dimming) working. Still some additional testing and code cleanup to do before I’m ready to do a pull request to the python lib & finally to the HA code.

Update (23/12): Today I managed to submit a PR to HA for the light control. Hopefully be applied at next HA release…

in 0.104 we should have solved almost all problems with the velbus integration.

Hello,
I’m a new user of Home assistant, i did try the build in Velbus integration with my velbus installation but did not suport the most of my modules, now i see there is Python-Velbus with better support and up to date.
But (sorry I’m new here) don’t understand how to add Python-Velbus to my new installation (on raspbery Pi4-HassOS 3.10)
Is there some kind of step by step manual to make the integration for a noob like me?
I have only experience with c# programming.

I don’t understand what you want to achieve. Using the Velbus integration at Home Assistant it automatically loads the Python-velbus lib in the background. Do you run the latest Home Assistant version (0.105.4 at the moment)?