Switchbot BT/Wifi Bulb - Very slow

I just purchased the SwitchBot Smart LED Light Bulb (WiFi & Bluetooth) to replace some Tuya devices that keep going offline. The setup was simple, and worked fine, until I moved them to where they are planned for. It’s a bit far for Bluetooth, but there is excellent WIFI signal there. However, it appears the device is still trying to use Bluetooth and takes 3-6 seconds to turn the bulbs on/off. My Tuya bulbs in the same spot turn on/off instantly.

I know, setup a Bluetooth proxy. Yes, I did that. And I see the mac address in the log (Proxying packet from - 60:55:F9:xx:xx:xx). But it’s still slow, it appears Home Assistant is still sending the commands from my internal Bluetooth card. I can’t get it to switch through the proxy.

But I shouldn’t need a proxy, it has wifi. I bought the bulbs to use over WIFI. How can I force Home Assistant to connect to my Wifi bulb using Wifi?

Thank you!