Switchbot Lock Pro add to HA

Ah, I thought the pro lock would’ve been properly supported at this point. I also need the unlatch functionality, something my Nuki has had issues with as well. I hope it will be supported soon, else I’d have to send it back…

I got the same stuff today. Tried following your steps but I can’t pair the hub with HA. Tried Settings>devices and service>devices>add device> add matter device>no it’s new. But I get “unable to pair” after scanned the QR code. Any idea why? I’ve set it up in switchbot app with wifi credentials and that worked fine. This is the first time using matter at all so I first installed the Matter addon.

You have to do the 15 second reset in order to pair it with HA.

From what I can tell, the original Switchbot lock had this support via the bluetooth integration. The Pro will be added at some point and should get this support too I guess. No idea about Matter though. I guess I’ll have to pick up a bluetooth receiver for HA when it gets the integration…

Tried that but still the same result.

Edit: got it to work! I just had to add the wifi via switchbot app first and, I don’t know if this made any difference but, I also changed my phone wifi to the 2.4ghz.

Thank you!

Do I need a SkyConnect or other USB device for Matter on my HA Pi in order to be able to have HA connect to the Seitchbot hub?

Connection fails for me every time. After it fails, the Switchbot app tells me the hib is connected, but when I click on “Matter Setup” in the app, it goes to Google Home (which I do have but I never tried connecting to that).

When I then reset the hub and try again, the same thing happens.

Unfortunately I get these periods that the lock gets disconnected / unavailable in HA. Anyone else experience this and have any idea how to fix this?

I didn’t have that problem yet. Could it be, that your Hub is not in connection range to your lock or WiFi?

You have to connect your lock to your hub, go to HA>Integration>Add Int.>Add Matter Device>No. It’s new.>Press the button on your hub for 15 seconds>Scan the QR code>Done.

No it’s just a few meters away and have no other wifi problems. It’s really strange. I don’t know how to fix it or troubleshoot.

Thanks a lot! I was pretty desperate, your solution worked for me as well.

Has anyone tried switching off cloud services afterwards?

It now works with the SwitchBot Bluetooth Integration, added in 2024.7.0

1 Like

great stuff !

Had it running the following way for a few days:
Lock → Hub Mini → as Matter device in Homekit → to Matter device in HA.
The lock worked really via matter, but the “unlock without opening” feature for latch locks is not present.
After pairing it as a Bluetooth device, there were some initial glitches with the status indicator (it kept showing as constantly unlocking or locking after use), but thankfully, those issues eventually cleared up on their own. I’m really anticipating the addition of the latch option, which would be incredibly convenient for me. It would eliminate the need to wait for a complete unlock when entering via the keypad, instead I could just “unlock but not open the latch” with a presence sensor. :slight_smile:
Edit: nevermind. When it’s unlocked it stays at “unlocking”…

1 Like

I’ve been unable to add the Lock Pro via the bluetooth integration. I’ve tried both methods, entering in my account information or entering in the encryption key, and for both I get an error message that reads “Unknown error occurred”. It takes a few minutes before that message is given so it seems like the request is timing out. Has anyone else had this issue? I had the same issue before with a regular Switchbot Lock but never tried to fix it.

Thanks, that worked fine for me to Reset the Hub Mini complete that is black and add it after that in the App as Secondary Device.

How did you do that then with the Home Key App?
Do you have as a device an home Pod mini or Apple TV?
Me not it seems that is necessary to do that.