Tahoma Blinds, Obstruction detected

Hello everyone,

Full disclosure i just started my HA journey !

I have integrated my blinds using the overkiz integration however i can’t seem to control the Venetian ones.

After poking around i realised that it’s not a connectivity issue because i can press the identify button though HA and it would work. For some reason there is an attribute called ‘Obstruction-detected’ and it’s set to TRUE for the blinds that are not working which leads me to believe it’s the reason i can’t control them.

Do you believe it’s the issue and if yes can change that attribute to FALSE ?

Thank you !

“Obstruction detected” means something is blocking the blinds from moving.
Changing the attribute will do no good, because the reason for the value in the attribute will still be present and it will be set again by the blinds.
Can you control them in other ways than HA? maybe directly on the blinds?

That’s what is bothering me, there is nothing blocking them!
I can still use the tahoma app to control them and also the somfy remote

Then you need to get in contact with the overkiz integration developers.
The integration should have a link to report an issue by clicking the threee dots in the integrations box on the HA integration page.

Overkiz is apparently a HA core integration.
Here is the link to the github page: Issues · home-assistant/core · GitHub

Allright will do !

Thank you very much !

I do not use the overkiz integration for blinds, so this is based on an educated guess. This may not be bug but a feature.

I myself am an author of another integration for blinds (on a different domotics platform). For that I created a feature to be able to set if there is an obstruction below the blind. This is functionality for blinds that are installed above inward turning windows. If the sensor on the window detects the window is open, then it informs the blind of the obstruction so it won’t come down on the open window. Tis could also be used for covers outside that should not open when there is too much wind.

So look if there is a service in the overkiz integration to set and clear the obstruction flag, or check in Tahoma itself if there is a way to link blinds to contact or wind sensors that may be causing this in Tahoma itself.

It would be awsome if this feature was built in to the HA cover for all implementations, iI now need to create templates to get this done. There’s a two year old architecture discussion about it that a contributor of the overkiz integration commented on, so I think that may have resulted in this feature.

Thanks for the reply. I have searched a bit, the only thing that comes close to a locked state is 3 sensors :
Priority lock timer
Target closure
Priority lock originator

I am new to HA so i don’t excatly know to check for services that can clear the obstruction flag :frowning:

The priority lock originator and timer seem to indicate what is the cause of the obstruction and how long it is locked for:

Myself seems to be one of the causes for a lock, which suggests some kind of way to have a manual lock.

I found the solution !
I remembered that my Somfy remote has a lock button where you can choose between Auto and Manual. When set to Manual apparently it stops it from working !

Thank you for the time to help me!

1 Like

Glad to read this. Indeed, currently, we don’t do anything with the lock information except exposing them (you have to enable them first).


1 Like

Thank you everyone :slight_smile: