Telldus TZWP-102 (Wall Plug with energy meter)


#1

Hi,
I’m having issues with the Telldus TZWP-102. It’s a wall plug that includes energy meter. Does anyone else have this issue? Or with another Wall Plug, something similar?

The test bench setup.
A Home Assistant running Z-Wave with a Aeotec Z-stick and 1 TZWP-102 Wall Plug.
Distance between Wall Plug and Z-Stick is less than 6 feet.
No other Wave devices
No Polling Intensity on device
Polling on Zwave in general is set to default

The Issue
It’s very slow.
The RTT is about 5-600ms.
Turning the Switch On/Off/On takes several seconds.

Settings:
1. Overcurrent protection: Enabled
2: Remember device status after power failure: Remember status
3: Send status in Lifeline when Load status change: Send Basic Report only when Load status is not changed by Z-Wave Command
4: LED Indicator: The LED follows the load status
16: Send report on change of power consumption (W): 50
(This parameter will send a power report automatically if the power value changes of x W (Watts) compared to the last report. Default 50.)
17: Send report on change of power consumption (%): 10
(This parameter will send a power report automatically if the power value changes of x % compared to the last report. Default 10.)
101: Power (W) report interval: 600
(This parameter defines the period of sending power reports. Default 600. 0=Disabled, 5-2678400 seconds)
102: Energy (kWh) report interval: 3600
(This parameter defines the period of sending energy reports. Default 3600. 0=Disabled, 5-2678400 seconds)
103: Voltage (V) report interval: 0
(This parameter defines the period of sending voltage reports. Default 0. 0=Disabled, 5-2678400 seconds)
104: Current (A) report interval: 0
(This parameter defines the period of sending current reports. Default 0. 0=Disabled, 5-2678400 seconds)

There really isn’t much more settings that can be changed.


#2

Have the same problem with the same device. Have you found any solution?


#3

No, not really. I’m going to try to reset my z-wave (Once HA 0.85 gets Z-Wave fixed). Maybe an update of OZW will be available. If it’s not working, I’ll try to add them without secure.

After that I’m out of ideas.


#4

Removed one plug and readded it as non secure, RTT dropped to 40 ms from>600 ms. UI seems to pick up state of switch without any delay. I’m on 0.85, upgrading didn’t mess up my z-wave. I guess it’s too early for a final verdict…