Testers needed for Netatmo climate (multiple thermostats or valves)


This is


Thank you very much! This works fine for me now!
I changed only one thiing, I don’t like, that my thermostats where shown as climate.testxxx. I changed the my coding, and deleted the hardcoded concat.


Really nice that this works now, this is an example on how I use this to stop heating when a window is opened (Netatmo promises this feature since last year, but did not publish is, this temperature sensor based algorithm will not beat a reed sensot attached to the window)

Thanks again to @Baosong_Shan

This is my example:

# Living Room
- alias: window open living room
  initial_state: 'on'
    platform: state
    entity_id: binary_sensor.lr_window
    to: 'on'
    - condition: template
      value_template: "{{ (states.sensor.netatmo_outside.state | float) < 18 }}"
    service: climate.set_temperature
      entity_id: climate.test_wz
      temperature: 12

- alias: window closed living room
  initial_state: 'on'
    platform: state
    entity_id: binary_sensor.lr_window
    to: 'off'
    service: climate.set_operation_mode
      entity_id: climate.test_wz
      operation_mode: Schedule


what sensors do you use?


Xiaomi door/window sensors toghether with a zigbee stick

I also don’t like the “test” prefix, where can I change that?


in the netatmo2.py in line 95 you have to change the code from
self._name = 'test_' + room_name
self._name = room_name

thanks for the sensor!


Hi Klagio, could you please re-pull it and try?


ahhh now I see new climate.test_xxxx entities. These works fine!!


I don’t like test_ either, and I’ve changed it to netatmo_ now, so one should get climate.netatmo_<room_name>. However, it may have problem if the same room name is shared in several "home"s.


This works for me as well. I see all my valves with the correct temperatures! Great work!!!
Only thing: my thermostat does not have a test_ device so I’m guessing this one is only detected by the official netatmo platform.


Please note my previous post, I didn’t see I had new entityies, I was using the old climate.xxxx_thermostat entities.

Thye new entities work fine.Yes I also prefer to take out the name test, but can do in customization


No, just my own change, in fact you can change to whatever you like.

Will try to submit to this contribution when I have more time…


you want me to try this too? The previous one is working!


of course when a window is open and outside is cold you should close the window, but why turn off heating … if you do it becomes even more cold inside :stuck_out_tongue:


You said you could not control two of them, no? Try the current one if controlling has some problem.


Finally after so much time, a perfectly working Netatmo thermostat component.Thank you all


IIRC you have to give a name to you house. Can’t you make it home-name_room-name to solve this problem?


Sure I can, but it is really a rare case, and I am worrying this could be kind of annoying for those (majority?) who use single home… Anyway, it will be automatically renamed if this happens, so will not affect correct operation.


Its to get fresh air in the rooms and this should also be done when its cold outside (depends on your ventilation system)
So save energy its smarter to turn off heating during ventialting the rooms and this way I can control it for each room seperatly.


Works perfectly on our 3 valves and my thermostat!

One thing I would like to fix is this “Unknown” status: