Testers needed for Netatmo climate (multiple thermostats or valves)


#168

As I explained, this was due to the response error, it is not critical as long as the next requests succeed, but I will try to add more protection.


#169

What do you mean with turn netatmo on and of?


#170

The thermostat supports ON/OFF as well. When turning OFF, it will show OFF and the current temperature on the thermostat screen. It might not be interesting, right?


#171

But this is only supported for the thermostat and not for the valves.

Would also be nice to be able to turn a valve on and off.

On would mean higher than current temp. Off lower than current temp without nowing the actual temperature.

I have two examples where this would be useful:

  1. Tell Alexa to turn on heating for one room (valve) when you like to have it warmer.
    (Now you have to say: „blabla 22 degree C“, so when its already at 22 it will not heat)

  2. Turn heating on by a Remote Control with the push of a button. When its cold tonight I don’t want to wake up my wife. So I flip my aqara cube (zigbee device) to turn the heat to 22 degrees for 10 minutes.
    But same issue again, if the room temp is already at or above 22 nothing will happen.

An option to turn the valve on or off would be nice for those usecases.

Hope I was clear enough.


#172

thank you very much! They are nice features!


#173

If I understand correctly, the feature you described is already supported by current version. Just change the mode to “Max” or “Hg”, right?


#174

So Hg turns the Valve to Anti-Frost-Mode (8 °C), but “Max” doesn’t do anything.

Does “Max” work for you? What does it do?


#175

Yes, “Max” takes my thermostat temperature to 25.5 and starts the boiler. Yours are only valves, right? I will check if there is something missing there.


#176

No, I have one thermostat and 4 valves.


#177

In this case, please try turning “Max” for the room where your thermostat resides and see if anything happens.


#178

Ok. So turning to max in the thermostat Room turns it to 25,5 deg C. I have no further valves in that room only the thermostat cube.

Nothing happens for the valves in other rooms.


#179

You should set the valve to max. A manual override of a valve will force the thermostat to switch on; you can set the standard duration of an override in the netmo settings, no clue if it can be set from HA. A manual override should heat up the valve room to the requested temperature but also heat up the thermostat room. That’s why I installed valves in the thermostat room as well. Works like a charm. Each room is heated up according to the requested schema without overheating the living room (where my thermostat is installed).


#180

In my case the thermostat is placed in the bathroom, where I have floor heating. So in this case I cannot add an additional valve. Also moving the thermostat to another room isn’t an option because than I can’t control the bathroom anymore.

I like an overheated bathroom more than a no dumb (not smart) bathroom.

The thing is turning a valve to “max” doesn’t do anything. This only works with the thermostat.


#181

I guess you don’t really have a HA/Netatmo2 module problem but more a heating-installation problem. I have no experience with floor heating but from what I hear from friends who have it they setup circuits with fixed temperature as the inertia of floor warming makes they cannot heat up a room quickly as with radiators.

How do you fix it with the Netatmo app or website. If you cannot do it with their app, you certainly will not be able to do it with HA.


#182

I don’t have a problem with my installation. All works fine.
The only thing I was asking about above is, if there is a function to turn a valve on (heating on) or off.

By switching to “Hg” mode you can turn off every single valve. But (At least for me) there is no way to turn a valve on, because “max” only works with the thermostat.
“Max” in the case of the thermostat means that it’s temp is set to 25,5 deg C.

So there is this service “max” for the valves but it doesn’t do anything. And I would suggest, if it is there it should do something or it shouldn’t be there.
Choose a valve and set its service to max. I think you will see that it doesn’t change anything.

Of course there is an easy workaround for this by simply setting the temperature of that valve to e.g. 25°C (max. heating).

So does “max” do something at your valves?


#183

I confirm that turning a valve to “max” does not help (it seems Netatmo does not support this, I will remove this mode from valves).


#184

I tend to respect the Netatmo API behavior and remove “max”/“off” from valves. As you said, you can do it by manual tuning.


#185

I‘m the same opinion.

„Max“ should be removed.

However there is no „off“ option for me. If you mean „Hg“ (whatever that stands for?) you could also leave this option because this works.
„Hg“ only triggers antifrost-mode, so we could also do this my setting the temp manual to e.g. 8


#186

OK, now I understand. I’ve never used the Max setting. My valves are set to a schema and if necessary a manual override is set. This is working quite nice, i.e. no complaints of the family :wink: and rooms are only heated when necessary.


#187

The reason why a max feature would be nice is one of my use cases.

I can avoid this by setting a redicously high temperature. So this whole thing isn’t really an issue.
But I think it would be better to use the current temperature (when the automation is triggered) + 1°C. Maybe the room would overheat pretty fast when I set to such a high temp.

EDIT:
I think something like this should work, but I don’t know how it has to be written:

This
temperature: '{{ states.sensor.netatmo_valve.state }} + 2'
and this
temperature: 'sensor.netatmo_valve + 2'

did not work