Testers wanted - Netatmo integration

Tags: #<Tag:0x00007f738f7b8018>

Hi @cgtobi

I have the Netatmo thermostat and I would like to test to contribute.

I’ve searched in HACS for Netatmo, but I haven’t found any Integration, should I search something else?

Thanks

1 Like

You need to add as a custom repository in HACS.

Url for repository is https://github.com/vlebourl/netatmo_custom

2 Likes

Thanks.

I will try it out.

I’ve made these steps, as stated in the Repository page

This repo is a custom component from the beta version of the official HA Netatmo component.

Add this repo as a custom repo in HACS and install it. Remove the old Netatmo integration. Reboot Home Assistant and configure the newly installed netatmo component through the integration page as per the old one.

  • install new repo in HACS
  • install the Netatmo Component integration from HACS
  • remove actual Netatmo from Integrations
  • tried to install the new integration (but I see only one, is it the correct one?)

Schermata 2020-06-12 alle 13.35.27

and then I get this message

Schermata 2020-06-12 alle 13.35.34

“The component is not configured. Please follow the documentation.” that should be the one I posted above."

I’ve tried also clearing browser cache and doing Command-Shift-R on Mac browser.

What am I doing wrong?
Thanks

Not the expert here, but think the steps above are in the wrong order. It should be
1 - remove existing Integration
2 - reboot
3 - install from HACS
4 - configure new Integration

If it were me I’d remove all Netatmo Integrations, reboot the system and then configure your Integration.
try that and maybe post here how you get on

(PS - there should only be one Integration available as anything installed to the custom_components folder will overwrite a core component of the same name, so the HACS Netatmo is (correctly) overwriting the Core Netatmo)

Thanks @Gav_in

The “standard” integration is not in the custom_components folder, so the new HACS integration should not overwrite anything, as far I know.

Now I’ve tried this way:

  • Legacy Netatmo integration is already removed from Integrations panel
  • remove the Netatmo Component integration from HACS
  • restart HA
  • install new repo in HACS
  • install the Netatmo Component integration from HACS
  • restart HA
  • tried to install the new integration

but I get same error.

Then I’ve removed the HACS component, restarted HA and tried to reinstall the legacy Integrations, but now I get the same error.
So I’ve restored last snapshot from tonight, restarted all the process as above, but same issue.

It’e really strange…

What can I try more @cgtobi ?

Thanks

Not sure on the actual issue you are having :thinking: but just for info…(and sorry to all for going off topic here)
As far as I know any component installed into custom_components overwrites a core component in terms of how it is loaded into HA.
So in this case \custom_components\netatmo will overwrite (i.e. be loaded instead of) the core netatmo component as they share the same folder name. Then if you were to delete the \custom_components\netatmo folder and reboot you’d be back to using the core integration.
This approach would allow you modify/fork the existing components without actually having to fork/build everything. :+1:

Yes, that is correct.
When I removed the new HACS component, before and after restarting HA, I’ve checked that in custom_components folder there were no netatmo folder, and it was like this.
That’s why I was surprised that the legacy Netatmo was having same error as the new one and I was not able to install it again.

BTW, I’m on 0.111.0

Not sure if I understand the actual issue. Do you see anything in the logs?

My fault, sorry… @Gav_in @cgtobi

I don’t know why I’ve removed, for some unknown reason, the

netatmo:
  client_id: !secret netatmo_client_id
  client_secret: !secret netatmo_client_secret

from configuration.yaml

So, now is easily installed and working and I can try to test.

I’ve installed Duck Dns and NGINX, but I don’t use it since I don’t have any open ports on my router, I always use VPN when I need to connect from outside.

Should it work anyway? Should I make anything in the configuration.yaml ?

Thanks

1 Like

Does this integration make Netatmo public weather sensors work again?

No. That is a different topic.

Webhook is not necessary but would provide that extra umph.

I’ve tried adding these lines to http:

  server_host: 127.0.0.1
  use_x_forwarded_for: true
  trusted_proxies: 127.0.0.1

but then HA is not reachable with local IP… :open_mouth:
so I will proceed without them

What should I check with thermostat with this new version?

Did you read the whole guide?

Thanks anyway.

You mean this?

If yes, some testing just now.

I’ve changed the temp from Netatmo app and see what’s happening in HA on a PC browser.

  • Changed without refreshing web browser, after 4 minutes I tried to refresh browser and some secs after it changed also in HA
  • Changed refreshing web browser just after, after 4 minutes I tried to refresh browser again and after 45 more secs, it changed also in HA

I’ve changed the temp in HA from PC Browser and see what’s happening in the Netatmo app

  • Changed in HA, the degrees changed in red, if I refresh the browser 2-4 secs sfter, it returns to previous value and on the App nothings changes
  • Changed in HA, but on the App nothings changes. If I close the App and reopen, it changes the value. In HA it’s still red. If I refresh web browser, the HA value returns to older value and the App will never sync, even if I close it.

Yeah, if you don’t have a setup with active webhook that is to be expected.

1 Like

Is it possible to have active webook without opening any port on router?

Yeah, with Nabu Casa for example.

1 Like