Thingsup BLE Beacon Scanner MQTT Config

my mechanic friend runs a repair shop with 2 separate garages, and I’m looking for a way to tag & track his expensive dewalt power tools (they have a habit of walking away…). I picked up 60 “new old stock” trackr pixels for $60 & replaced all batteries for $8.
then:

  1. activated them in the SwiftFinder app (used 3 accounts, 20 trackers per - app gets wonky if you add too many)
  2. affixed 1 tracker to each dewalt tool & battery
  3. mounted a cheap android phone on a mag charger near the tool cabinet in each garage
  4. installed SwiftFinder app on each phone, using 2 DIFFERENT accounts from step 1 (to update cloud w/gps loc)
  5. all employees have SwiftFinder app installed on their phones to enable crowd gps updates in the field (using their own accts)
  6. installed Thingsup BLE Beacon Scanner app on the 2 shop phones, to capture beacon data
  7. I assumed Thingsup would send beacon data via MQTT thru my eclipse broker to ha

phones, eclipse & ha are all on the same network.

MQTT broker & HA is working fine for my wink relays. also tested & worked fine w/Beacon MQTT app from turbulator (tested w/some Tiles - but that app is limited to 4 iBeacon devices, and doesn’t support the pixels out of the box). Thingsup picks up all the pixel traffic perfectly. But I can’t figure out how to get the app to send to my local mosquitto broker (MQTT Explorer doesn’t show any traffic from the app).

the android BLE MQTT route seemed to be the cheapest and most effective option for the project, instead of trying to set up the usual BLE gateways, and if I can crack the MQTT communication issue from the app then I’m sure I can make this work (I’ll send a notification if a tracker misses some number of beacons).

I’ve reached out to Thingsup support, but haven’t heard back. 2 other users posted messages on the app’s google play store page saying they also haven’t gotten MQTT working, and haven’t gotten any help from support. The MQTT config shown in the play store screen shot uses Thingsup’s broker on the standard port 1883, but I tried TLS on port 8883 as well. Interestingly, the app page on apple doesn’t even show the MQTT page (I don’t have an iPhone, so I can’t test that).

Has anybody had any experience w/this app? I guess my next step will be learning how to sniff the traffic from my phone to my broker to see if it’s sending anything at all.

update: wireshark shows a malformed packet on the connect command, but I can’t figure out why. in thingsup I’ve tried every combo of mqtt/websockets, 1883/8883, tls/no tls (but I’m not sure I’ve set up certs correctly). it seems to connect if I change to websockets, but then I don’t think I’m actually transmitting any beacon data.

for now I’m going to forget thingsup & just let the swiftfinder app update tracker locs to the cloud, and esp32’s to communicate local presense to ha.