TKBhome dual wallswitch with relay (or dimmer) - right buttons howto?

Hello, im a Noob here and at the beginning with ha. I am usen

All light-devices in my appartment are zwave devices. at the raspy is an aeon stick. All this works fine, most out of the box. Also my first automations.

Only one problem with my: Wenzhou TKB Control System dual-switches.

here the status of one of these dual-switches:

averageRequestRTT: 23
averageResponseRTT: 357
capabilities: routing,listening,beaming
friendly_name: LichtWC
is_awake: true
is_failed: false
is_info_received: true
is_ready: true
is_zwave_plus: true
lastRequestRTT: 24
lastResponseRTT: 34
manufacturer_name: Wenzhou TKB Control System
max_baud_rate: 40000
neighbors: 1,5,6
new_entity_id: zwave.lichtwc
node_id: 12
node_name: LichtWC
old_entity_id: zwave.lichtwc_12
product_name: TZ56 Wall Switch On/Off
query_stage: Complete
receivedCnt: 94
receivedDups: 22
receivedTS: 2017-08-28 08:15:14:285
receivedUnsolicited: 12
retries: 0
sentCnt: 60
sentFailed: 0
sentTS: 2017-08-28 08:15:14:251

so wide so good. Now my Problem: the tkbhome dual switchs have (in zwave) 4 groups to use. Group 1 is for the left switch. this is for the internal relay and is working well. Group 2 and group 3 are for the right switch (normal operation and double-click) for two additional zwave functions.

i want to use these buttons not in zwave direct. i want to send the signals to hass to do automations and groups over hass.

i cant find any clue how to do such an oparation.

So i ask for community help at this point.

Please, does anybody have a hint for me?

Associate the controller into group 2 and 3. Use the Group card of the Zwave UI config.

Got the same problem. It seems thar HA detects only the left switch zwave command.
In the past, I had installed a different home automation sw on my Pi (jeedom) and there were detected both, right and left as z-wave switches ready to be used in any automation. Maybe is due to the version of the openzwave installed?. I don’t know. I’m hopeless trying to find a solution.
Please any help?
Thanks in advance.

I found the next error in the OZW log when I press the right tab:

2018-02-06 20:10:48.792 Warning, Exception: Manager.cpp:2499 - 102 - ValueID passed to GetValueFloatPrecision is not a Decimal Value
2018-02-06 20:10:48.792 Warning, Exception: Manager.cpp:2499 - 102 - ValueID passed to GetValueFloatPrecision is not a Decimal Value

Maybe is the origin of the issue but no idea about what to do.

Also quite a noob with Hass and started to learn how z-wave could be used. Everything related to z-wave is still in the test bed.

I have TKB TZ-37, which has two relays. Its buttons can be associated to different groups. My plan is to use double taps to control a group of lights including zwave, zigbee and telldus devices and to perform other automations in the server. TZ-37 manual says:

Group 2 Control: If you associate a Z-Wave device into Group 2, you can turn that device ON or OFF by tapping the top or bottom of the left switch twice. You can brighten or dim devices by tapping the switch once then push and hold the top or bottom of the left switch. The load attached to the switch is not affected.The LED on the left switch will indicate the status of Group 2. Group 2 will be polled at a specific interval and the LED on the left switch will indicate the status of Group 2. The polling interval can be configured. The Group2 name is On /Off Dimmer 1(Profile MSB=0x20,Profile LSB=0x01).

Group 3 Control: If you associate … into Group 3, … of the right switch twice. The Group3 name is on off dimmer 2 (Profile MSB=0x20,Profile LSB=0x02).

Thanks to hint from turbokongen, I was able to activate both groups by associating them to the controller (ZME UZB1). You needed to restart hass several time before this was working, but that is another story.

First (small) problem I have is that I do not see any messages in logs related to scenes as defined in Hass docs. Using logs the following automation worked:

- alias: ZWave test 2
    platform: event
    event_type: zwave.node_event
      entity_id: zwave.front_door_node 
      basic_level: 0
    service: light.turn_off
    entity_id: light.bed_east

- alias: ZWave test 3
    platform: event
    event_type: zwave.node_event
      entity_id: zwave.front_door_node 
      basic_level: 255
    service: light.turn_on
    entity_id: light.bed_east

2nd problem I have is that I cannot distinguish double taps from the left and right buttons. Information is the same both in OZWlog and hass.log. So the above automation action happens from both devices,

The 3rd problem is that this stops working after a certain time with other drawbacks. When I turn on the relay using the switch, the light is turned on but Hass does not see it. USB stick is not flashing and nothing comes to logs.I can still control the switch from Hass. Additionally, the same association becomes copied to Group 1, which actually might cause the the previous?

I need to remove all associations and restart Hass to restore even the basic operations for this node.

TZ-37 is not in manufacturer_spefific.xml, but I have configured to use TZ-56.xml, which seems to be very same.

Any ideas?

So, did anyone solve this? Make second button work on TKB switch? =(

I also wonder if some solve TKB wallswitch! anyone?
I have TZ56D: left button is working out of the box, right button (on/off) is working with instruction above and the automation of @Willew but it gets triggered by one AND double tab! any solutions?

Doing regular checkup on this thread. Still no luck on my end, the only thing I could do it just using right button to control other zwave devices, but that’s not through hass, it’s basically just zwave <-> zwave communication. As far as I know it should even work if the bridge is turned off. Either case, not very useful for automations :frowning: