Toon van Eneco custom component


#243

It is super easy.
Look at the link of boltgolt.
Currently it’s a custom component so you have to download it and place it manually in the config folder of you home assistant.
I am not 100% if in the hass.io install you can also place custom components, if not then just use the hassbian install.

If you have any questions let us know.


#244

i have installed rasbian and then installed home assistant.
So i have the hass.io i believe.
It is installed on a Raspberry pi Model B+ V1.2
Is there an hassbian version of?


#245

Hassbian (or others): https://home-assistant.io/docs/installation/


#246

Hello,
Have everything up and running.
I have put my sd card in my cpmputer and looking for the yaml file.
Where can i find this?
And also to copy files to other directory’s
Should i make them myself?


#247

I made an ssh connection and i changed the config.yaml.
But i don’t have the dir’s where i have to put the py files.
So still don’t have the device.
Do i have to make this dir’s myself and where do they have to go?


#248

You will have to create the directories yes.


#249

Ok no problem i could do this but is there somebody who could please tell me where to create every directory?
i made directory’s in the root like this.
/config/python_scripts/climate.toon.py

In the yaml file i copied also the txt as described overhere but in the dashboard of home assistant nothing apears.
Still get the homescreen with dissmiss in it what i should disable in the config.yaml.
I cannot find something in this file to disable.
I know it is enoying that somebody asks something what you guy’s do already for years.
Then you will think very easy pffffffff, but i know it from myself that i did this also in the past but i learned that somebody who is complete new to something everything will be abracadabra.
At least i know how to do stuff in ssh but i have no idea where to create the folders etc.

can somebody please explane me in beginners language how to.
From there i will explore further.
Thank you in advange.


#250

Thats fine, but the documentation is very clear.

toon.py —> /custom_components
climate/toon.py —> /custom_components/climate
sensor/toon.py —> /custom_components/sensor
switch/toon.py —> /custom_components/switch

You will have to create the “custom_components” folder in the /config/ directory
You will have to create the “climate” + “sensor” + switch" directory in the “/config/custom_components” directory.

copy all the relevant files to the folders.

I would recommend you read all the getting started documentation and play around with it, this will be the best way to get familiar with the configuration and all of it’s possibilities.

what helped me a lot is to look at configurations of other people: https://home-assistant.io/cookbook/


#251

Hi Peteralm,

Did you install Hassbian as Puckstar suggested or did you stick with Hass.io? That kind of is vital information. Although I haven’t seen it confirmed in this topic, I myself got ToonHA up and running in Hassbian in right away, while I did not got it to work in Hass.io. So for Hass.io I’m waiting for it to get merged to mainline.

I’m curious if anybody got it to work in Hass.io? But from my understanding it has to be rebuild to a docker container to work with Hass.io.


#252

Hi Housebeer, it works good for me in hass.io


#253

Did your follow the exact same steps as described on github? making a new “custom_component” dir in the config directory? Or did it require some different set-up? Knowing that it works in Hassio I might want to take another shot at it


#254

Correct, the same steps work for me.


#255

Now busy with installing hassbian.
Then we will try again.


#256

i am waiting a hour by now. the hasbian is at the prompt and i can read starting installing homeassistant.

But untill now i cannot connect to the web interface.
http://ipraspberry:8123

No homeassistant


#257

Hassbian is running.
Also samba is running so i can easy go to the configuration.yaml
Now in this homeassistant directory i should create custom_components and climate or not?


#258

Sorry for all my posts.
I have my toon in the dashboard.
It is reacting on it so far so good.
The only thing is , i can use the comfort, away on the webinterface but on the phone app i cannot.
Why?


#259

Nobbody knows why the sleep, away, home, comfort is not available in the homeassistant android app and it is in the web interface.


#260

Thanks for the effort on this component

Installation on Hassio with the custom folders worked for me as well.

I do notice some temporary connection errors in the logging, not sure how often this will happen as i just configured to component in hassio but most of the errors i see in the logging are related to Toon: Fibaro Wall Plugs

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='api.toon.eu', port=443): Max retries exceeded with url: //toon/v3/261071/status (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x72925e90>: Failed to establish a new connection: [Errno -3] Try again',))

or

Updating state for switch.wasmachine (<class 'custom_components.switch.toon.EnecoSmartPlug'>) took 0.675 seconds. Please report platform to the developers at https://goo.gl/Nvioub

2018-03-13 21:08:04 ERROR (MainThread) [homeassistant.helpers.entity] Update for switch.wasmachine fails
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/urllib3/connection.py", line 141, in _new_conn
    (self.host, self.port), self.timeout, **extra_kw)
  File "/usr/lib/python3.6/site-packages/urllib3/util/connection.py", line 60, in create_connection
    for res in socket.getaddrinfo(host, port, family, socket.SOCK_STREAM):
  File "/usr/lib/python3.6/socket.py", line 745, in getaddrinfo
    for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Try again

#261

Can someone help me with the installation ?
I have followed the instructions, created an account for the Toon API and copied the files to the locations.
When I first did a Configuration check I got an error in my configuration.yaml it is because of the @ character in the e-mail address that is used as username for the Toon App logon.
So I used the \ character in front of the @ to try to escape it, not sure if that is the correct way to do it but when I do another configuration check I receive the following error:
Configuration invalid
Check config
Testing configuration at /home/homeassistant/.homeassistant
Fatal error while loading config: invalid syntax (toon.py, line 7)
Failed config
General Errors:
- invalid syntax (toon.py, line 7)

Successful config (partial)

Anyone knows what I’m doing wrong ? Is it the \ that is not correct ?

Regards,

Stefan


#262

Hi @svanhattum, I don’t think that anyone can help if you don’t paste your configuration. Obfuscate you personal info with garbage and paste here what you have on your config please.