Toon van Eneco custom component


#81

You got it working? How did you do it?


#82

I’m using home assistant on an Ubuntu 16.04 installation, so that might be the difference maker. Just followed the installation instructions by dropping the mentioned toon.py files into the folders and added the configuration and it just worked. I did notice it immediately installing toonlib on first restart.


#83

Hi @boltgolt,

Thanks for replying.

I got in contact with costas at github. My problem is that i have zwave plug’s that only switches and doesn’t measure the power usage. Because of this the component gave an error. I got a workaround from costas for the moment.

Feeling happy already! Hopefully the switching part will work soon.


#84

Had the same error. After I restarted my Docker container the error was gone.


#85

Anyone using this with hass.io?

edit: and can I just buy a second hand cheap Toon from Marktplaats and hook it up? Therefore not needing to pay the subscription?


#86

I believe that unless your Toon is rooted you can’t interact with it via Hass.
Or you need a Toon op Afstand subscription with Eneco.

If it’s possible without rooted Toon and without Eneco subscription I’m very very much interested because that’ll save me the monthly subscription (which was increased recently also).


#87

Thanks! Did you not try rooting it yourself? I’m thinking of buying a used Toon just for this purpose.


#88

I don’t really dare to do it. Maybe if there is a very very clear guideline and examples of people that did it and where it’s working.
Also I need to know what it means regarding updates to the device and my contract in general.


#89

As of today, Toon is now open
https://www.toonapi.com

Toon® is now open for all kinds of products, services and applications. 
Join our fast growing community and create smarter homes and a smarter life 
for more then half a million Toon users in The Netherlands. 

HTH


#90

Interesting. Though I don’t have programming skills so others will need to build new things :).
By the way it’s bad English (even I know though I’m not native English). It says “for more then half”, should be “for more than half”.

Anyway I looked for someone to root my Toon but it seems my version is quite difficult to root.


#91

Hi. I’m trying to install your component but I’m missing something.

The log says:
2017-10-16 22:33:14 ERROR (SyncWorker_1) [homeassistant.util.package] Unable to install package toonlib==1.1.0: Could not find a version that satisfies the requirement toonlib==1.1.0 (from versions: 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.2.0, 0.3.0, 0.4.0, 0.5b0, 0.5.0, 1.0.0, 1.0.1, 1.0.2)
No matching distribution found for toonlib==1.1.0
2017-10-16 22:33:14 ERROR (MainThread) [homeassistant.setup] Not initializing toon because could not install dependency toonlib==1.1.0

I’m running hass.io. Apparently it can’t find the newest version. Any idea how I can install it manually? I cannot use “pip” in SSH.


#92

@eddemans I pushed an update today that bumped the dependency to 1.1.0, but i looks like that version isn’t available in the package indexes yet. You can check the latest version here and wait for it to update, or ask @costas to push the new package.


#93

Thanks for your quick reply. I’ll wait then. I’m sure costas is in already in the process of it.


#94

Hi @eddemans, I forgot :frowning: . The package is uploaded now :slight_smile:


#95

Could you help me to install this via HASS.IO ? :slight_smile:

Thanks in advance !


#96

After reboot it works right away, thanks @costas!


#97

Hi @Imperial-Guard. I just did what it says on the https://github.com/krocat/ToonHA page. The files need to be copied to the machine (for instance via Samba) in the path mentioned. Then you add the mentioned lines into the configuration.yaml file. It should work right away!


#98

Ah it was working for me, but homehow last weekend my Toon is not working anymore.
I got the following erros:

2017-10-17 08:53:25 WARNING (MainThread) [homeassistant.helpers.entity] Update of climate.toon_van_eneco is taking over 10 seconds
2017-10-17 08:53:25 WARNING (MainThread) [homeassistant.helpers.entity] Update of sensor.power_current is taking over 10 seconds


#99

If you have it already but have problems, why did you ask for help with install? Better to ask for help with update because they’ve been updating the component.


#100

Unfortunately this is a known bug. The eneco API we use is unstable and will timeout from time to time. We’re working on a solution but in the meantime the component should start working again once eneco is back or on the first run after a hass restart.

Could you help me by trying to use the Toon app while you’re experiencing timeouts and trying things like upping the temperature and changing the program? In my case these actions will be either highly delayed or never actually be executed on the Toon.