Toon van Eneco custom component


#142

fixed it, maybe a dirty way but hey, its working

in the scenes I changed the operation mode to the corresponding modes . First it wasnt working then I found out that the modes are case sensitive. So in the scene I changed to eco, heat etc and now its working again


#143

Thanks for the feedback on the new docs @costas and @remkolodder, they have been merged and are live on the hass site now.


#144

Is it a recent thing that the Toon API became less responsive/stable? I used to use Toon with OpenHAB and that seemed to work more stably than it is now with hass (e.g. thermostat setpoint not reflected/updated in hass even though setpoint was changed through hass (or otherwise), many many ‘update takes longer than 10 seconds’ messages in the log) though that was over half a year back.

I almost feel like my IP address is being API rate-limited by Eneco :hushed:


#145

The API is highly unstable and has been for as long as i’m involved in this. Looking at old forum posts around the web it seems like it’s a common problem, i also experience it in the Toon app itself.

You could try to follow the instructions to install the latest version from github. That version tries to relog in certain cases and is much more reliable in my experience.


#146

I’ll give that a go tonight, thanks!

Pretty ridiculous that the API is so unstable and slow, but I guess Eneco aren’t as interested in improving it…


#147

Well, at the moment it’s not working. Even with the Toon app. 3 days straight… I think something is wrong at Toon servers side.


#148

Ah that would make sense in the problems that I am seeing as well. Perhaps I should have read this first before opening an issue. Will try @boltgolt’s suggestion to use the github version for the toon thingy again (I used that before it was converted to a dedicated hass component)


#149

The API seems completely unresponsive at the moment (sending back even more empty responses than usual), i’m sure they are working on it but in the mean time it might be a good idea to disable the Toon component for now. The IT guys at Eneco are probably having a really bad few days and relog spam from this component doesn’t make that a whole lot better.


#150

Disabled it… maybe it’s time to root the toon… :smirk:


#151

After restarting home assistant today i got a invalid configuration on the toon component.

Could this be something related to the unresponsive API?

If so, maybe an idea to improve the error handling for this component if possible?

For example add a state field: Toon Status: Up ( service/api reachable ) / Down ( service/api unreachable )


#152

The invalid configuration is because Toon has a general problem. Toon servers are not reachable even with the Toon app. This has been going on since Monday. Eneco/Toon is working on this issue.

Topic on Toon forum (in Dutch)


#153

they now show at Toonopafstand:

That might be the problem :slight_smile:

Kind regards

Bert


#154

If i recall correctly, they shut down the website a long time ago. The app still worked though and we use the app backend for this component.


#155

It seems to be working again, at least for me. Had to reboot Toon by pulling it from the wall…


#156

Here also working again, had to reboot Toon and we are back online again… but I think I am going to root my Toon. To much down time , and paying monthly for what service ?! I understand that something can go wrong in IT, but almost 4 days of downtime ?!


#157

Is it possible to exclude a switchplug’s energy sensor in home-assistant? I have a few plugs connected to the toon but they don’t measure power. This is what I get the whole day in de errorlog:

2017-11-16 22:20:42 WARNING (MainThread) [homeassistant.helpers.entity] Update of sensor.tv_hoek_today_energy is taking over 10 seconds


#158

Is there somehow a possibility to read the sensor of the Toon if hotwater is used?
I see this visual on my Toon with a symbol. I would like this to you use it in further automations.


#159

You can, i implemented it after the merged version in the main hass repo. If you follow the installation instructions at https://github.com/krocat/ToonHA you should get a burner binary sensor.


#160

Just bumping my question up… Is it possible?


#161

If i recall correctly this was fixed in https://github.com/krocat/ToonHA/pull/11, correct me if i’m wrong. Are you using the (latest) custom component?