Tradfri motion sensor takes a long time to change status

I have a tradfri motion sensor and I want to use it to turn my toilet light on and off. I’ve read some forums about the motion sensor and came to the conclusion that it’s a real pain to get it to work.

What i want:

  • turn on light when motion detected (this is working so far with a little split second delay)
  • turn of when no more motion detected
- id: '1589124277451'
  alias: Turn on toilet light
  description: ''
  trigger:
  - entity_id: binary_sensor.tradfri_motion_sensor_toilet_occupancy
    from: 'off'
    platform: state
    to: 'on'
  condition: []
  action:
  - brightness_pct: 80
    device_id: 9eb331e3a82a4280bf1dd3933a06c1ca
    domain: light
    entity_id: light.tradfri_led_bulb_toilet_light
    type: turn_on
- id: '1589124580200'
  alias: Turn off toilet light
  description: ''
  trigger:
  - entity_id: binary_sensor.tradfri_motion_sensor_toilet_occupancy
    from: 'on'
    platform: state
    to: 'off'
  condition: []
  action:
  - device_id: 9eb331e3a82a4280bf1dd3933a06c1ca
    domain: light
    entity_id: light.tradfri_led_bulb_toilet_light
    type: turn_off

This works, in theory. The problem is that the binary_sensor takes a really long time to update. More than 5 minutes. I could use one automation with a delay but then the on time of the light would be fixed, not really smart. I’ve already set the delay on the actual motion sensor to the 1min minimum.

How can I fix/ bypass this?

Do you have the old version or the new version of the IKEA motion sensor ? The new one takes exactly 3 minutes after no motion detected to switch off.

The old one with the 1-10 min timer on the back. But after sensing someone it has some sort of blackout for a very long time. It takes around 12 minutes to register that there is no motion. So even if i set it to 1 min it still waits a long long time.

Long story short, the tradfri motion sensor is somehow stuck on the 10 -12 min blackout time. Switched it for another and everythings fine now.