Trouble with config

Hi,

I can’t update my system to 0.105.3. I got these error in the log file

Can someone help me? I don’t know how I should fix this.

Can you access your config via samba ?

Comment out everything you can.
Boot the system
Uncomment things bit by bit til the problem comes back.
Comment out that bit again
Check it boots
Continue uncommenting the rest (there may be more than one area)
When you’ve narrowed it down we can help with what you have left

Edit: not a config issue, read below

I can access via samba…

But I don’t know which file it want me to check?
I do not recognize the file names

My apologies, I skim read your post, it looked like you had a configuration issue.
Re-reading this I’m now assuming you have installed home assistant (the old hassio) in Docker on Raspbian.?
What is your hardware, what is your OS and what did you try to do.?
I’m assuming it was working before and you just tried updating?
Did you take a snap shot before you updated and did you store it ‘elsewhere’ (is it accessible?)

I am running 0.104.3 on a Raspberry Pi 3 Model B+

I have tried updating several times, but I get these errors every time
I got snapshots both on the DS-card, on my iMac and in dropbox. So i gave restored my HA several times this week.
But I really want to update my system, but I don’t know why it wont let me.

I assume you are running hassos then ?

Given the nature of the errors I would suggest you just do a clean install and restore the snapshot

Funny story… I have tried that.

When I restore my snapshot, my system runs 0.104.3 again… I don’t know why.
I have unchecked the field with 0.104.3 but when HA reboots, it is running 104…

Get a new hassos image, flash it to sd, let the pi boot, leave it an hour to 90 minutes to be sure its updated, THEN restore the snapshot.

Your current card seems corrupted in some way, hopefully just a file write error which should be cleared with the new flash.

Thx - I will try that

Are you using netatmo? I hit this when I hadn’t properly updated to the new config property names.

Yes - I’m using Netatmo Climate… But the entities are up-to-date and I’ve checked everywhere.
Should I try to comment all netatmo out, and check the configuration?

Maybe remove netamo and update and then add it back

I’m not sure if you followed the steps for the breaking changes, but the property names were changed. They are now client_id and client_secret. I found that having the old names gave the error you listed. It seems like a bug that this wasn’t handled more gracefully.