Trouble with downloaded VM files

New to Home Assistant, attempting to install for the very first time, I am using VirtualBox and am getting this error when trying to add the .vdi file
Could not get the storage format of the medium ‘C:\VMs\hassos_ova-5.13.vdi’ (VERR_NOT_SUPPORTED).

I have also tried the .qcow2 download and get the same error

And the VMware .ova file gives me this error
Failed to open virtual machine: SHA digest of file home-assistant.vmdk does not match manifest.

Any help would be much appreciated

Did you follow the instructions as describe here to set up your virtualbox before you import the VDI.
Using the latest VirtualBox.
Choose the instruction appropriate to “VirtualBox”

The download image might be corrupted re download, or try the older one.


Thanks for the reply!

I did finally figure out my issue and apparently it was just me being dumb.

The files downloaded as .xz compressed files. Apparently .XZ is an LZMA/LZMA2 compression algorithm that I was unaware/unfamiliar of/with and I instead of extracting the files as I should have I just removed the trailing .xz from the file name as some sort of artifact (renamed hassos_ova-5.13.vdi.xz to hassos_ova-5.13.vdi). no ware did I see anything about these downloads coming as compressed files. Once I extracted them all worked as it should.