Troubleshooting blank dashboards on iOS (Safari & Companion App)

A minor update or two ago (currently running 2022.11.04 - containerized), Safari on iOS and the iOS Companion App started having problems loading the default dashboard. Both platforms login, and briefly start to render the main dashboard before going to a blank screen. I am occasionally able to get to the settings menu in the companion app and have tried removing and reinstalling the app as well as deleting and reconnecting to the server. Once, the dashboard rendered just long enough for me to get to the dashboard sidebar, where I was able to choose my regular (YAML defined) dashboard. So long as I stayed on that view, things worked fine.

Things work fine on all desktop platforms (Safari, Firefox, Chrome) and there are no relevant errors in the HASS logs nor in the console mode of those desktop browsers. I’ve disabled almost all of my HACS elements and looked for any oddities. There are multiple threads both here and on discord, but no solutions, nor any ways to even diagnosing on these platforms.

Any clues how I can even start to debug this, let alone fix?