Troubleshooting the notifications service iOS 16

I have been using HA for about a year, but not used notifications before. Now I want to set some up. I tried using Call Service from the Developer Tools (using a web interface) but I cannot get it to work.

  1. The companion app works fine. It is logged on via Nabu Casa
  2. When I set up the Call Service, I checked the entity name matches that in the device (under setting companion app): “Andy’s iPhone (2)” translates automatically to notify.mobile_app_andys_iphone_2
  3. Notifications for HA are enabled in the phone’s settings
  4. The Call Service gives me a green tick after I run it … but
  5. No notification is shown on the phone, nor found in the app

What am I missing? How do I find the error?

Hi, have you seen this: Getting Started | Home Assistant Companion Docs

Yes, thanks. Nothing abut troubleshooting in there.

I think the problem has something to do with phone naming and system settings for notifications, possibly the iOS version…

I experimented by installing the companion app on two old phones – an iPhone 8 SE running iOS 15.7.1 and an iPhone 8 Plus running iOS 15.6.1 that I happened to have. After a bit of fiddling, I got notifications working on both of these, one logged on as me (admin) and one as a non-admin user, but still not on my iPhone 11 running iOS 16.6.

I notice that once logged in (remotely via Nabu Casa) a change in the device name (using Settings → General → About → Name) is quickly reflected in the available entity names within Home Assistant → Developer Tools → Services. You can only select one that actually exists, e.g. Notifications: Send a notification via mobile_app_andys_iphone_2.

Another factor that got it working in one of the three cases was to reset the notification variables: Settings → Notifications → Home Assistant; check settings are enabled; then at the bottom of that page select ‘Home Assistant Notification Settings’; then press 'reset at the bottom of that page.

This was all trial and error. Now:

  1. I wish there were a document that stated clearly all the necessary settings (maybe some of my steps are not necessary)
  2. I still have not got notifications working on my iPhone 11 (Andy’s iPhone 2) even though I did the same there as on the other two phones.

Any ideas?
Could it be an iOS 16 issue??
Is there a way of finding out where the notification is being blocked or lost?

I don’t really have a solution/answer, sorry.
You could change the title to add/change the category to be “Mobile Apps”.