Trusted Networks Auth method prevents NodeRED Login

Since installing Hass.io under docker in Ubuntu, I’ve never been able to get past the 502 Bad Gatweway error, but I’ve been able to login using the port number 1880 with a URL.

Now, after enabling trusted networks as an authentication provider (seems it’s the only way I can get a kiosk tablet to automatically login as a kiosk user), NodeRED login fails, and there are no errors in the NodeRED logs about it.

Have you enabled homeassistant auth?

  auth_providers:
    - type: trusted_networks
        trusted_networks:
          - 192.168.0.0/24
          - fd00::/8
    - type: homeassistant

I have done that, only not with:

-fd00::/8  <---- what does this do?

In addition, I’m running HA in a work environment with multiple users. I don’t want to enable anyone to just open up HA and choose a user, since there’s room for error in that process and no password is required.

I’m using Compact Custom Header to manage exceptions for users to display or not display certain elements of the UI.

What I want to be able to do is give a single computer on the network access to HA without needing a login. That would be my personal laptop.

What would I do next?

This is example for ipv6, You can do that https://www.home-assistant.io/docs/authentication/providers/#skip-login-page-examples