TTS is not longer working (it worked before!)?

Hello!

This is the configuration for tts in my configuration.yaml:

tts:
  - platform: google_translate
    language: 'de'

This has worked before in an older Home Assistant version (last time I tested it on May 20th), now I am at 0.110.5 and it is not working.

I tested it with the service menu:
Bildschirmfoto 2020-06-06 um 17.04.16

But nothing is happening, no files are created in the folder config/tts where all the old test-TTS files are.
I found a little bit later in the log this:

2020-06-06 17:20:44 ERROR (MainThread) [homeassistant.components.google_translate.tts] Timeout for google speech
2020-06-06 17:20:44 ERROR (MainThread) [homeassistant.components.tts] Error on init TTS: No TTS from google_translate for 'Hallo'

I tested it also with the media_player dialog:
Bildschirmfoto 2020-06-06 um 17.05.20

But also here nothing is happening only this in the log:

2020-06-06 17:21:15 ERROR (MainThread) [homeassistant.components.google_translate.tts] Timeout for google speech
2020-06-06 17:21:15 ERROR (MainThread) [homeassistant.components.tts] Error on init TTS: No TTS from google_translate for 'iehjr gphjsd gpodjsf gojsdf gkjdsf glkjdf gkj rpgoijergpo ijer ogijepogijeogpijeporgijerpoighjrijghidogh djfhg pdfhg pdoghj podgjh dpogj podifjg oidgj oigj goij gojd gopihjsd gophjsd gpojdspfogij dopgij doijg opdifjg oidj goijd goijd ogj dpofgij dpoigj pogij oij oijg peoirjg poeirjg poeirjg poeirgj opigj epoigj eporigj. peoigj poegij esgoij epogij eprgoije rgoijerg oeigj '

What is going wrong here?

The configuration is still the same, I am using Duckdns integration, so my Pi is only available via https://xxxxxxxxx.duckdns.org:8123
Also I disabled Adguard for this test to have no problems here.

Why are no tts files generated?

Adding the base_url option to the tts configuration fixed this for me. It is supposed to be optional but things changed in 0.110.

Oh, I forgot to mention, I tested this but it didn’t changed a thing.
I used there “https://xxxxxxxxx.duckdns.org:8123”.

1 Like

Then I don’t know :upside_down_face:

Interestingly, I tested it after you wrote this and now it works. I can not tell why, but I tested since two days and nothing happened and now after your post it works.
Very strange!

It was my post. It fixed it.

1 Like

Temporarily it worked. I managed to get my LMS something to say a few times. But now I only see this in the log:

2020-06-06 23:25:42 ERROR (MainThread) [homeassistant.components.google_translate.tts] Timeout for google speech
2020-06-06 23:25:42 ERROR (MainThread) [homeassistant.components.tts] Error on init TTS: No TTS from google_translate for 'Hallo'

Where can I do something to make it work again?

Bump up your logging to get more clues.

I don’t know if this is new info or I just never noticed it, the documentation at this link says you might need to configure external_url in configuration.yaml

https://www.home-assistant.io/integrations/tts/

there is a link in the above page that leads you to

https://www.home-assistant.io/docs/configuration/basic/

I have done that but no luck. Now I am using ReversoTTS (installed via HACS) and this is working without any problem together with LMS. Also the voices are of better quality!

Is it possible to read data from a template? For example, temperature or current time as well as google tts.
I used the same template and it doesn’t work. It only reads the words written in the template.

Hi @pepe59 didi you resolve this?

Yes, after the fix today, google tts works well, including reading data from templates. Great satisfaction.
I’m running HA version 2021.1.1 and HassOS 5.10 and everything works perfectly.